OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Dictionaries don't recognize prefixed words

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Barry II
General User
General User


Joined: 18 Sep 2007
Posts: 40

PostPosted: Sat Jan 26, 2008 1:03 am    Post subject: Dictionaries don't recognize prefixed words Reply with quote

Is there a way to tell Writer that "unindexed" and other words with "un" and other prefixes are correctly spelled without adding each one to the dictionary individually?
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Sat Jan 26, 2008 8:13 am    Post subject: Re: Dictionaries don't recognize prefixed words Reply with quote

Barry II wrote:
Is there a way to tell Writer that "unindexed" and other words with "un" and other prefixes are correctly spelled without adding each one to the dictionary individually?


Not that I have seen. Given the irregular spelling of English it is probably very difficult if not impossible in a simple English spell checker.
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
Barry II
General User
General User


Joined: 18 Sep 2007
Posts: 40

PostPosted: Sat Jan 26, 2008 11:12 pm    Post subject: Reply with quote

I found a list of words with "un" prefixes and I decided to open a custom OO Writer dictionary file that I created to see if I can edit it directly. It's located at:

C:\Documents and Settings\Owner\Application Data\OpenOffice.org2\user\wordbook\barry's custom dictionary.dic

I know I'd need a script because the word delimiters depend on the word length, I think, but I experimented manually anyway. I opened it in UltraEdit and changed a single letter in one of the words to make the word misspelled but the same length, then saved it. I know the edited version was saved because every time I open it in UltraEdit, the word is misspelled. But when I view the word list in OO Writer (Tools > Options > Language Settings > Writing Aids) , the word isn't misspelled! I tried deleting temporary files through XP's control panel and in IE, but my edit of the dic file still doesn't take effect. What's happening?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group