OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Problem Typing Hebrew (solved)

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
lodp
Newbie
Newbie


Joined: 15 Dec 2005
Posts: 4
Location: Vienna, Austria

PostPosted: Mon Mar 13, 2006 8:19 am    Post subject: Problem Typing Hebrew (solved) Reply with quote

Hi y'all,

My Problem was solved in the process of typing this, I'm posting this anyway, so that the solution will turn up when somebody does a forum search.

When I switched my keyboard to Hebrew, it worked beautifully in pretty much all applications. But in OpenOffice, i only got small empty squares, no matter which font I chose.

I'm working on Ubuntu 5.10 with KDE. I had got CTL enabled in OO, Culmus 0.101-2 was installed, the metapackage for Hebrew language support was installed, as were spell-checker packages (myspell, hspell).

The Problem existed only in my English installation of Openoffice 2.02 (it didn't work in 2.01 and 1.9x either). I tried to install the Hebrew version of OO (from openoffice.org.il, my Hebrew just sufficed to do that) - and it worked there. But I needed to be able to use the English edition with Hebrew.

Turns out it was a fonts problem. The Culmus version that I used wasn't compatible with Openoffice. I downgraded Culmus from 0.101-2 to 0.93 and -!מזל טוב it worked. All the fonts are there in the selector now - Frank Ruehl, Nachieli etc.

You can find versions of culmus up to 0.100 on the culmus sourceforge page files here: http://sourceforge.net/project/showfiles.php?group_id=59410).
There's only .rpm packages there unfortunately. I used alien <filename> to convert the thing to a .deb file and then sudo dpkg -i <filename> to install.

there's supposed to be 0.101-4 unstable release, but the links on http://culmus.sourceforg.org are dead, and i can't seem to find it elsewhere. In the meantime I'll stick with 0.93.

so long!
Back to top
View user's profile Send private message
Efrat
Newbie
Newbie


Joined: 25 Mar 2006
Posts: 2

PostPosted: Sat Mar 25, 2006 3:20 pm    Post subject: Possibly Similar Problem Reply with quote

Hello,

I'm using OO2 on Ubuntu 5.10. In OO.Writer, I see "transparent" Hebrew when I type (in other words, I don't see anything - the cursor moves and that's all she wrote). All other apps seem to display Hebrew fine. For emphasis: אין בעיה בשאר האפליקציות. Your reply seemed the most relevant, but I suck at linux - I just know to run synaptic (in synaptic, I searched for Hebrew, then installed everything). So when you write about downgrading culmus, I just don't know how to do it. Could you please help out?

Thanks,

Efrat
Back to top
View user's profile Send private message
lodp
Newbie
Newbie


Joined: 15 Dec 2005
Posts: 4
Location: Vienna, Austria

PostPosted: Sun Mar 26, 2006 7:18 am    Post subject: Reply with quote

sure thing, pal

i actually discovered a way in which you don't have to downgrade to 0.93. it all seems to be a problem with the place that OO checks for fonts. culmus 0.102 seems to install the fonts in /usr/X11R6/lib/X11/fonts/Type1 - but OO doesn't find them there. so i just placed a link of that folder in /usr/share/fonts/ - where OO apparently DOES find them.

placing a link is pretty much like copying a folder, only it's easier to keep the folders in sync - when there's an update on the fonts, for example.

btw, OO doesn't seem to work so great for vowel placement, i started a thread on that HERE
Back to top
View user's profile Send private message
Efrat
Newbie
Newbie


Joined: 25 Mar 2006
Posts: 2

PostPosted: Sun Mar 26, 2006 3:27 pm    Post subject: Dude, you rock! Reply with quote

ln'd the stuff, and it worked like a charm!

Many Thanks,
תודה רבה

Efrat
Back to top
View user's profile Send private message
AndyKC
Newbie
Newbie


Joined: 07 Jun 2006
Posts: 2

PostPosted: Wed Jun 07, 2006 11:22 pm    Post subject: Easier Hebrew typing ? Reply with quote

I have just installed OpenOffice 2.0 on Windows 2000 in my native English on and want to type Hebrew in a Writer document. I've read the previous posts, but I don't understand the talks of culmus and other references. How do I most simply enable typing of Hebrew fonts?

I've gotten into the CTL options and specified Hebrew as the default font for a CTL document, but I can't figure out how to make my document get into CTL mode.

I can change the text flow to Right-to-Left and select what should be a Hebrew font (Aharoni, David), but the text just stays in English letters although it goes from right to left.

Any suggestions?

Thank you!
Andy
Back to top
View user's profile Send private message
Robert Tucker
Moderator
Moderator


Joined: 16 Aug 2004
Posts: 3407
Location: Manchester UK

PostPosted: Wed Jun 07, 2006 11:45 pm    Post subject: Reply with quote

Maybe you need to switch to a Hebrew keymap?

http://tlt.its.psu.edu/suggestions/international/keyboards/winkey.html#switch
Back to top
View user's profile Send private message
AndyKC
Newbie
Newbie


Joined: 07 Jun 2006
Posts: 2

PostPosted: Thu Jun 08, 2006 7:13 am    Post subject: Simple Hebrew problem solved Reply with quote

Thank you! That worked.

In Windows 2000, the Control Panel for Keyboard allowed me to specify "Hebrew" as an input locale.

Thanks for the fast feedback!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group