OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Problem Exporting Graphics in Draw

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Draw
View previous topic :: View next topic  
Author Message
chipmonger
General User
General User


Joined: 28 Mar 2006
Posts: 5

PostPosted: Tue Mar 28, 2006 8:00 pm    Post subject: Problem Exporting Graphics in Draw Reply with quote

If I create a new drawing, import a graphic into it and then export the drawing to a .eps file, when I open the saved file in other programs (the Gimp for one) the graphics are not appearing. If I open the .eps file in OOo Draw, then the graphic appears.

Any ideas?
Back to top
View user's profile Send private message
roadbike
General User
General User


Joined: 23 Mar 2006
Posts: 23

PostPosted: Sun Apr 02, 2006 4:10 pm    Post subject: Reply with quote

What kind of graphic are you trying to import?..........bmp.....jpg........svg????????
Back to top
View user's profile Send private message
chipmonger
General User
General User


Joined: 28 Mar 2006
Posts: 5

PostPosted: Sun Apr 02, 2006 6:31 pm    Post subject: Reply with quote

roadbike wrote:
What kind of graphic are you trying to import?..........bmp.....jpg........svg????????


I'm using eps files - need to have scalable files, and there's no svg import.

To replicate the problem:

1) Create an eps file on disk.
2) Open OOo Draw and either open the eps file or select 'Insert', 'Picture', 'From file' and import it that way.
3) Select the graphic just imported and select 'File', 'Export'. Export as an eps file.
4) If you open the file from step 3 in OOa Draw, it will appear as normal.
5) Open the file from step 3 in the Gimp, and it will appear blank.

This problem will occur if other objects are selected during the export as well. For example, you import an eps file to a drawing that contains text. Try to export both the text and graphic, only the text will appear in the Gimp.
Back to top
View user's profile Send private message
roadbike
General User
General User


Joined: 23 Mar 2006
Posts: 23

PostPosted: Sun Apr 02, 2006 7:19 pm    Post subject: Reply with quote

Have you tried printing from the gimp after you imported the image even though what you see onscreen is blank?
Back to top
View user's profile Send private message
chipmonger
General User
General User


Joined: 28 Mar 2006
Posts: 5

PostPosted: Sun Apr 02, 2006 8:22 pm    Post subject: Reply with quote

Yes, it's blank.

The file is also blank in the Gnome Image Viewer and Inkscape.
Back to top
View user's profile Send private message
ericsp
Newbie
Newbie


Joined: 26 Apr 2006
Posts: 1

PostPosted: Wed Apr 26, 2006 12:09 pm    Post subject: impoirting eps into draw Reply with quote

I have a similar problem: I generated an eps in scigraphica and when I try to import it into Draw, it does not work. Is this an OOfice problem?

Eric
Back to top
View user's profile Send private message
acknak
Moderator
Moderator


Joined: 13 Aug 2004
Posts: 4295
Location: ~ 40°N,75°W

PostPosted: Wed Apr 26, 2006 8:07 pm    Post subject: Reply with quote

Quote:
If I create a new drawing, import a graphic into it and then export the drawing to a .eps file, when I open the saved file in other programs (the Gimp for one) the graphics are not appearing. ...

Same results for me also (2.0.2/Linux). Printing fails the same way.
There are lots of glitches with EPS import/export. Looks like yours is already reported:
Issue 32607
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Draw All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group