OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Impossible to change date format in header/footer?
Goto page 1, 2  Next
 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc
View previous topic :: View next topic  
Author Message
antonbijl
OOo Advocate
OOo Advocate


Joined: 04 Aug 2003
Posts: 291
Location: Pretoria, South Africa

PostPosted: Tue Nov 04, 2003 1:42 am    Post subject: Impossible to change date format in header/footer? Reply with quote

Hi all

I would like to insert the current date in the header of a spreadsheet in the ISO format YYYY-MM-DD. It seems like there is no way of doing this.

The ideal solution for me would be if I could just change the default date format in OOo, but it doesn't seem this is possible (although one should think...). The default date format is MM/DD/YYYY, despite the fact that my locale setting is South Africa and as far as I know nobody in South Africa writes the date that way (with the possible exception of a few US expats).

So the next best solution would be to insert my own field in there with the date in the format I prefer, but in the Header dialog there is no option to insert anything but the standard seven fields and using the date field results in the OOo default format MM/DD/YYYY being used.

As a last resort, I thought I would use the standard field, display the field code and see if I could hack it to use a different format. However, there is no option in the OOo Spreadsheet options to display field codes and setting this option in the OOo Text Document options has no effect on the fields in the Spreadsheet header.

So now I'm stuck with inserting the date manually every time. Surely there must be a better way.

Any ideas?

Cheers

Anton
Back to top
View user's profile Send private message
tony.groves
OOo Enthusiast
OOo Enthusiast


Joined: 24 Aug 2003
Posts: 117
Location: Ireland

PostPosted: Tue Nov 04, 2003 11:30 am    Post subject: Reply with quote

I don't know if you've tried this, but you can change your locale settings using Tools -> Options -> Language Settings -> Languages. The settings there determine the date format that will be used.
Back to top
View user's profile Send private message
The Liquidator
Super User
Super User


Joined: 27 Feb 2003
Posts: 1368
Location: Manchester, UK

PostPosted: Tue Nov 04, 2003 3:14 pm    Post subject: Reply with quote

Alternatively, instead of selecting insert\fields\date select other instead and you will find loads of date formats. If the format you want isn't there, you can define it with "additional formats".

Ian
Back to top
View user's profile Send private message
antonbijl
OOo Advocate
OOo Advocate


Joined: 04 Aug 2003
Posts: 291
Location: Pretoria, South Africa

PostPosted: Tue Nov 04, 2003 9:43 pm    Post subject: Reply with quote

Hi guys

Thanks for suggestions.

Tony, I've already tried that without any effect.

Ian, the problem is that in the header dialog none of the menus are available. So I'm not using the insert menu. The only options available in this dialog are:
1 - Click on one of the seven field insert buttons - these are standard buttons and when you click on the date button it inserts the date in the OOo std format of MM/DD/YYYY without regard for the locale setting and without any option to change it
2 - Click on OK, Cancel or Help
3 - Enter text
Right-clicking on any of the controls in this dialog does nothing.

I access this dialog from the spreadsheet menu by going Format > Page > Header {tab} > Edit {button}, but it can also be accessed from the page preview.

If there is another way of accessing it that would allow me to use the Insert menu I will gladly try it.

Cheers

Anton
Back to top
View user's profile Send private message
antonbijl
OOo Advocate
OOo Advocate


Joined: 04 Aug 2003
Posts: 291
Location: Pretoria, South Africa

PostPosted: Tue Nov 04, 2003 9:53 pm    Post subject: Reply with quote

BTW, I'm running OOo 1.1.0 on Windows XP Professional

Anton
Back to top
View user's profile Send private message
freiheit
OOo Advocate
OOo Advocate


Joined: 06 Sep 2003
Posts: 372
Location: California

PostPosted: Wed Nov 05, 2003 12:22 am    Post subject: I see the same thing Reply with quote

This definitely appears to be a shortcoming. I can't find any way around it, either. Even inserting a field in a text document and trying to copy/paste it into a spreadsheet header only pastes the text as static text. And the Ctrl-F2 shortcut (in Writer) to open the Other Fields dialog doesn't work in the Calc header edit dialog.

Don "Freiheit" Eitner
Back to top
View user's profile Send private message Visit poster's website
swamp
Guest





PostPosted: Wed Nov 05, 2003 11:12 am    Post subject: Reply with quote

hi,

maybe this will help.

I selected the OOo given format and right clicked on the date in the footer
and changed to whatever I liked, e.g. 2003-11-05

gl
cheers

@Anton: say hello to S.A. for me.
thx
Back to top
antonbijl
OOo Advocate
OOo Advocate


Joined: 04 Aug 2003
Posts: 291
Location: Pretoria, South Africa

PostPosted: Wed Nov 05, 2003 11:37 pm    Post subject: Reply with quote

Swamp

Are you sure? When I right-click on the date field in either the Calc header or footer absolutely nothing happens.

Are you on 1.1.0 and Windows?

Cheers

Anton
Back to top
View user's profile Send private message
antonbijl
OOo Advocate
OOo Advocate


Joined: 04 Aug 2003
Posts: 291
Location: Pretoria, South Africa

PostPosted: Wed Nov 05, 2003 11:51 pm    Post subject: Reply with quote

Hi all

I've now logged this as an issue (22183)
http://www.openoffice.org/issues/show_bug.cgi?id=22183

Cheers

Anton
Back to top
View user's profile Send private message
swamp
Guest





PostPosted: Thu Nov 06, 2003 12:33 am    Post subject: Reply with quote

Hi Anton,

I've got OOo1.1.0 on Linux: debian sid. Haven't tested it on Windows yet. Will do
this evening.

My reply wasn't that accurate. I've inserted the given format in the footer. Placed the curser in front of, e.g. the date filed in the footer. Right clicked and selected, I think in the Englisch Menu it'll be the "field" item, got it in german and is called "Feldbefehl". Then you can change the wanted format.

Please reply if it works. I'll test it on Windows at about 06:00 pm.

cheers
Back to top
tony.groves
OOo Enthusiast
OOo Enthusiast


Joined: 24 Aug 2003
Posts: 117
Location: Ireland

PostPosted: Thu Nov 06, 2003 12:39 am    Post subject: Reply with quote

Anton -

I've posted a screenshot to that issue showing that it works for me.
Back to top
View user's profile Send private message
antonbijl
OOo Advocate
OOo Advocate


Joined: 04 Aug 2003
Posts: 291
Location: Pretoria, South Africa

PostPosted: Thu Nov 06, 2003 3:28 am    Post subject: Reply with quote

Hi all

I can confirm that I was wrong about it not being possible to change the date format. The date format applied in the header edit dialog when you click on the insert date field button is definitely taken from the locale settings in OOo. However, the date format for the South African locale is incorrect (MM/DD/YYYY as opposed to YYYY/MM/DD).

I've logged this in issue 22190 http://www.openoffice.org/issues/show_bug.cgi?id=22190

Swamp, I'll still try your suggestion.

Cheers
Back to top
View user's profile Send private message
antonbijl
OOo Advocate
OOo Advocate


Joined: 04 Aug 2003
Posts: 291
Location: Pretoria, South Africa

PostPosted: Thu Nov 06, 2003 8:47 am    Post subject: Reply with quote

swamp

I tried what you said, but no luck. It works just like you said for headers and footers in Writer, but not in Calc. In the spreadsheet header edit dialog, when right-clicking does nothing (as in no menu whatsoever, anywhere while that dialog is active).

Cheers
Back to top
View user's profile Send private message
EddieJohnson
Newbie
Newbie


Joined: 30 Jun 2010
Posts: 1

PostPosted: Wed Jun 30, 2010 12:26 pm    Post subject: Reply with quote

So its almost 7 years later and this still has not been resolved?

We use ISO format dates exclusively in our office and I still can not find a way to insert the date code in a Calc header in 3.0.1 that doesn't use the braindead mm/dd/yy format.

Is there a way to create a custom locale, using USA but changing date to ISO format?
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Wed Jun 30, 2010 1:10 pm    Post subject: Reply with quote

EddieJohnson wrote:
So its almost 7 years later and this still has not been resolved?

We use ISO format dates exclusively in our office and I still can not find a way to insert the date code in a Calc header in 3.0.1 that doesn't use the braindead mm/dd/yy format.

Is there a way to create a custom locale, using USA but changing date to ISO format?


It looks just as stupid as always. I get dd/mm/yy as I use a Canadian locale You can always type it in by hand Rolling Eyes or change your locale. Argh!
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group