OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Change link styles : color and underline

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Site Feedback
View previous topic :: View next topic  
Author Message
goa103
OOo Advocate
OOo Advocate


Joined: 11 May 2003
Posts: 279

PostPosted: Sun Mar 14, 2004 4:34 am    Post subject: Change link styles : color and underline Reply with quote

Hello,

I'm surprised by the styles you use for the links. No underline, nearly the same color as normal text. So it's pretty hard to guess if a text is a link or a plain text. I think you should at least underline all links or lighten the color. The link is only underlined when the mouse hovers it.

Example :

Quote:
This is a sentence with a link. Where is it ?


...
Okay that one was a joke, no link eheh :p.

Serious example :

Quote:
This is a sentence with a link. Where is it ?


Not that hard with a short paragraph but on this topic for example, it's hard to find the links to click... In this paragraph for example you have to click the this topic link, did you see it ?

Okay I think it's pretty obvious for everyone. I hope it will help you improve OOoForum and more importantly, make it more accessible (Hidden link, find Charlie :p).

JM
_________________
An OOo mascot designer
Back to top
View user's profile Send private message
draude
Administrator
Administrator


Joined: 10 Dec 2002
Posts: 353
Location: San Francisco

PostPosted: Fri Mar 19, 2004 11:21 am    Post subject: Reply with quote

Hi JM,

I had never really thought about that but you make a good point. Your example illustrates the point quite effectively. Funny how that works.

I'll take a look at the style sheet and see about changing this.

Thanks.
Ed
Back to top
View user's profile Send private message Visit poster's website
goa103
OOo Advocate
OOo Advocate


Joined: 11 May 2003
Posts: 279

PostPosted: Wed Apr 21, 2004 6:59 am    Post subject: Reply with quote

draude wrote:
Hi JM,

I had never really thought about that but you make a good point. Your example illustrates the point quite effectively. Funny how that works.

I'll take a look at the style sheet and see about changing this.


Hi Ed,

I saw you didn't update the style sheets yet. Maybe I can help you with it. I quickly checked the subSilver.css file (http://www.oooforum.org/forum/templates/subSilver/subSilver.css) and these lines should be updated :

Quote:
a.postlink:link { text-decoration: none; color : #002B84 }
a.postlink:visited { text-decoration: none; color : #35424D; }
a.postlink:hover { text-decoration: underline; color : #56636D}


A link is only underlined when you hover it so you could just replace none by underline for the 2 first CSS properties. Only default links are underlined :

Quote:
a:link,a:active,a:visited { color : #002B84; }


Some examples, using the url tag :

Quote:
I really think you should ask your question on OOoForum.org.


We don't really see the link, it's hidden and the user has to guess that it should click on OOoForum.org to visit it.

Same example without a link :

Quote:
I really think you should ask your question on OOoForum.org.


We don't really see the difference but there should be one.

A last example but using a different approach. That time I won't use the url tag in order to show the URL to click to the user :

Quote:
I really think you should ask your question on OOoForum.org ( http://www.oooforum.org/ ).


That time it uses a different style and the link is underlined. The user obviously understand that it should click the link to visit the website. Using the url[/u] tag, you get the following style :

Quote:
I really think you should ask your question on OOoForum.org ( http://www.oooforum.org/ ).


2 different styles, there should only remain one (Highlander ? ^^).

Remember Depeche Mode ?

Quote:
It's just a question of styyyyyyyyyyyle... Just a question of style ^^


So I think the idea would be to use these lines :

Quote:
a.postlink:link { text-decoration: underline; color : #002B84 }
a.postlink:visited { text-decoration: underline; color : #35424D; }
a.postlink:hover { text-decoration: underline; color : #56636D}


Maybe you should even use the color of the defaut link : [i]002B84
for all link status but the hover one.

JM
_________________
An OOo mascot designer
Back to top
View user's profile Send private message
goa103
OOo Advocate
OOo Advocate


Joined: 11 May 2003
Posts: 279

PostPosted: Thu Jun 10, 2004 1:06 am    Post subject: Reply with quote

To draude,

Hello,

Sorry to bother you again with it but I really think you should update the styles. As a web designers and developers I can really help. I will take some time if needed to update the few lines from the CSS file. I'm posting a new thread right now and noticed all my list were hidden because of the colors.

So do not hesitate to ask me if you need help to update the CSS file, it's just a question of minute if you provide me with a way to update it, I can even use the existing CSS file and send it to you.

Thanks for your help,
JM
_________________
An OOo mascot designer
Back to top
View user's profile Send private message
jotus
General User
General User


Joined: 17 Jun 2004
Posts: 11
Location: Atlanta, GA

PostPosted: Thu Jun 17, 2004 12:29 pm    Post subject: Reply with quote

yes, i agree
Back to top
View user's profile Send private message MSN Messenger
RGB
Super User
Super User


Joined: 25 Nov 2003
Posts: 1743
Location: In Lombardy, near a glass of red Tuscany wine

PostPosted: Fri Jun 18, 2004 1:12 am    Post subject: Reply with quote

Also I. Is easy to lost the links with this configuration
Back to top
View user's profile Send private message
draude
Administrator
Administrator


Joined: 10 Dec 2002
Posts: 353
Location: San Francisco

PostPosted: Fri Jul 23, 2004 4:22 pm    Post subject: Reply with quote

Okay, finally got around to fixing this. Sorry for the delay.

Cheers,
Ed
Back to top
View user's profile Send private message Visit poster's website
goa103
OOo Advocate
OOo Advocate


Joined: 11 May 2003
Posts: 279

PostPosted: Sat Jul 24, 2004 12:09 am    Post subject: Reply with quote

Hi Ed,

Man we thought you were dead Smile.

draude wrote:
Okay, finally got around to fixing this. Sorry for the delay.


It took you some time to update the stylesheet but you did it well !

Thanks,
JM
_________________
An OOo mascot designer
Back to top
View user's profile Send private message
draude
Administrator
Administrator


Joined: 10 Dec 2002
Posts: 353
Location: San Francisco

PostPosted: Sat Jul 24, 2004 10:04 am    Post subject: Reply with quote

goa103 wrote:
Hi Ed,

Man we thought you were dead Smile.

Rumors of my demise were highly exaggerated. Smile

goa103 wrote:
It took you some time to update the stylesheet but you did it well !

Thanks. After digging through the stylesheets and making the fix, I reread your post above and realized you had the solution there the entire time! Oh well. I guess it never hurts to refamiliarize yourself with how your stylesheets work.

Ed
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Site Feedback All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group