OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

how to make consistent bullet to text spacing in Word / OO

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
gerrykirk
Newbie
Newbie


Joined: 10 Mar 2003
Posts: 3
Location: Sault Ste Marie, ON, Canada

PostPosted: Mon Mar 10, 2003 10:53 am    Post subject: how to make consistent bullet to text spacing in Word / OO Reply with quote

Lists created in MS Word, when opened in OO, have the text snug up against the bullet, even though in Word, there is more spacing.

Lists created in OO, when opened in Word, have the text snug up against the bullet, even though in OO, there is more spacing.

What is the proper way to set up spacing, so that both are consistent?

Using:
Word XP
OpenOffice 1.0.1

Thanks,
Gerry
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
ftack
Moderator
Moderator


Joined: 27 Jan 2003
Posts: 3102
Location: Belgium

PostPosted: Tue Mar 11, 2003 12:44 am    Post subject: Reply with quote

Many problems on the Writer forum boil down to problems in conversion of Office documents. As long as the Office formats are proprietary and secret, expecting a seamless conversion is unrealistic. My advise is, if you need to exchange with a word user, then accept little imperfections in layout during the editing stage. Create logically structured documents, using styles and automatic numbering whenever possible. These convert properly between Word and OOo Writer. Then perform the final formatting in your favorite wordprocessor. If you have used styles, this will proceed efficiently. Print the final tweaked product to PDF for everyones viewing pleasure Razz
Back to top
View user's profile Send private message
The Liquidator
Super User
Super User


Joined: 27 Feb 2003
Posts: 1368
Location: Manchester, UK

PostPosted: Tue Mar 11, 2003 6:10 am    Post subject: Reply with quote

Hi

I noted this problem with SO5, although only with docs that had been edited in SO. A workaround (for numbers at any rate) for me was to use numbering format (available in the stylist) instead of the numbering button. By creating styles for the various levels of indent and saving in a template the format was Word Compliant.

If doing this, you also want to go into tools/autoformat and turn off automatic numbering otherwise the problem returns. You cannot let OO automate the process. So you go:

Type number/Tab/Type Text/Return (at paragraph end)

Repeat process. It's a lot quicker than it actually sounds in fact a typist would probably find it quicker than with the button.

Also I can tell you that this problem appears to have been fixed in Build 644.

Ian
Back to top
View user's profile Send private message
gerrykirk
Newbie
Newbie


Joined: 10 Mar 2003
Posts: 3
Location: Sault Ste Marie, ON, Canada

PostPosted: Fri Mar 14, 2003 10:58 am    Post subject: Have been using styles Reply with quote

I (almost) always use styles to format my documents. I've been using a combination of the Numbering 1 paragraph style and the Numbering 1 number style.

I am saving this file in Word format from OO. When I open it in Word, the indenting to the text is gone. Basically the styles specify how close the text should be from the item number. There is no tab involved.

I also find that other things get numbered, like headings, even though I hadn't numbered it.

So, I might try the suggestion of a) type number b) press Tab c) type text, but to me this isn't using styles, at least the way I understand it. I'm willing to be enlightened.

Gerry
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
The Liquidator
Super User
Super User


Joined: 27 Feb 2003
Posts: 1368
Location: Manchester, UK

PostPosted: Fri Mar 14, 2003 4:06 pm    Post subject: Reply with quote

Yes, it is using styles - in the purest sense.

For example, I took the default style document and put all my preferred styles in it. Included in those are INM numbering 1/2/3/4/5. These were achieved by taking the styles in the stylist, editing them by changing from .50cm to .70cm increments, and then deleting the resulting text, finally saving that document as a template, which I then opted to use as my default, all my other templatesand documents thereafterbeing based thereon.

Doing things that way means you only have to do this exercise once, as the styles are in every document you create by selecting "new". It is particularly useful when you receive docs for editing and return. You can copy and paste the contents of the original into a "new" document and apply those styles to the text so it looks right so you send it back.

One thing to look for is that when you hit the number/bullet icons the space is a StarOffice Graphic which Word cannot read. This option gets you round this, hard-formatting a pre-dfeined tab space into the document. The reason you have to stop the automation is that when you allow this to happen (when you hit return at the end of the paragraph) the space is the same old graphic (which Word can't read etc).

This may sound long-winded, but you only do it once, and you will be surprised at how quick it can be inoperation.While you construct the template, think of all other useful things you may want to have available and put them in as well. Smile

Ian
Back to top
View user's profile Send private message
gerrykirk
Newbie
Newbie


Joined: 10 Mar 2003
Posts: 3
Location: Sault Ste Marie, ON, Canada

PostPosted: Tue Mar 25, 2003 8:52 am    Post subject: Still lose tab settings Reply with quote

I don't get it. OpenOffice doesn't seem to use tabs in the number formatting, so when I open up the document in Word, the text is scrunched next to the number. I'm using the Numbering 1 style.

I have autonumbering turned off.
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
The Liquidator
Super User
Super User


Joined: 27 Feb 2003
Posts: 1368
Location: Manchester, UK

PostPosted: Tue Mar 25, 2003 9:05 am    Post subject: Reply with quote

When you are doing the document, after typing in the number are you actually hitting the tab to create the indent? If so, it should definitely work. If it does not, I can only surmise that in Word XP good old M$ have gone and changed the format again! Works fine with 97 and 2000, so long as you have autonumbering turned off.

One point I don't think I covered is that the paragraph style should have a defined indent distance but with a Minus indent for the first line. If the minus figure is not there, you will I expect have a problem.

I have stopped doing this now. You might save yourself a load of hassle by getting the OO1.1 beta which now inserts a tab space when you hit the number button, with the caveat I make above about Word XP.
Back to top
View user's profile Send private message
CarlH
Guest





PostPosted: Fri Apr 11, 2003 2:11 pm    Post subject: Bullets Reply with quote

Not sure if I understand the problem correctly. The bullets are scrunched up to start, but then you can adjust the spacing between the lines to be whatever you want. Thus spread them out.
Back to top
The Liquidator
Super User
Super User


Joined: 27 Feb 2003
Posts: 1368
Location: Manchester, UK

PostPosted: Fri Apr 11, 2003 4:45 pm    Post subject: Reply with quote

Hi Carl

The problem is not one of formatting, but of conversion.

Depends very much on the OOo version used. There were problems either way between Word and OOo (and SO). When opening a Word doc, because Word describes most styles as "normal" OOo at times got it wrong.

Word docs made in OOo use a graphical space between the number and the text which Word could not read and so when opened in Word the 1st line of text appeared right next to the number i.e there was no indent on the 1st line.

Now sorted in the OOo1.1 beta, which instead of a graphic inserts a tab, unless of course MS change the format again.

Ian
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group