OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

decimal separator

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc
View previous topic :: View next topic  
Author Message
cyrain
General User
General User


Joined: 13 May 2006
Posts: 8

PostPosted: Wed Sep 20, 2006 1:28 pm    Post subject: decimal separator Reply with quote

Greetings,

This thing is driving me nuts :
I have a csv files where numbers are of this form :
xx.yy like 25.48

My OpenOffice is french and doesn't recognize the dot as a decimal separator.

So i went in the cell, right click, change format to number and replaced the "," with a dot -> nope. :
0.0271

becomes this '0.0271

and is still not a number Sad

any ideas please ?


Many thx !!
Back to top
View user's profile Send private message
BillP
Super User
Super User


Joined: 07 Jan 2006
Posts: 2703

PostPosted: Wed Sep 20, 2006 1:50 pm    Post subject: Re: decimal separator Reply with quote

cyrain wrote:
So i went in the cell, right click, change format to number and replaced the "," with a dot -> nope. :
0.0271

becomes this '0.0271

and is still not a number Sad!


Shouldn't you have replaced . with , instead of , with . ?
Back to top
View user's profile Send private message
cyrain
General User
General User


Joined: 13 May 2006
Posts: 8

PostPosted: Wed Sep 20, 2006 1:56 pm    Post subject: still .. Reply with quote

I think I was not clear enough.

In the format box, the format in the lower zone is like this :

0,00 note the ",".

In my cell, the decimal separator is a dot.
So I assumed that I needed to tell OO that the new decimal separator is a dot instead of a comma.
Back to top
View user's profile Send private message
BillP
Super User
Super User


Joined: 07 Jan 2006
Posts: 2703

PostPosted: Wed Sep 20, 2006 3:17 pm    Post subject: Reply with quote

The decimal separator depends on the Locale setting in Tools > Options > Language Settings > Settings. Try changing the Locale setting to one which uses the dot as the decimal separator, opening the csv file then switching back to the French Locale setting.

I did find this issue related to your problem:
http://qa.openoffice.org/issues/show_bug.cgi?id=57868
Back to top
View user's profile Send private message
cyrain
General User
General User


Joined: 13 May 2006
Posts: 8

PostPosted: Thu Sep 28, 2006 12:04 pm    Post subject: [SOLVED] Reply with quote

Yes !

That works, thank you very much !!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group