OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Possible Bug with Dialog Organizer

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
DVezina
OOo Advocate
OOo Advocate


Joined: 29 Sep 2006
Posts: 248
Location: Orlando

PostPosted: Thu Oct 05, 2006 8:54 am    Post subject: Possible Bug with Dialog Organizer Reply with quote

This thread is related to my post earlier today. In attempt to move dialogs from "My Macros" to the document macros - I ran into this problem.

1. Create a Dialog under:
My Macros/Standard/Module1

2. Save document and reopen

3. Use the Dialog Organizer to drag dialog to:
Untitled1/Standard/myInterface
(or really anywhere outside of "My Macros")

4. Exit document and discard changes - I had made other changes in my template that I did not wish to save.

* Dialog is missing - apparently deleted? Not in My Macros or Untitled. I hope I didn't just lose 2 weeks of work.
Back to top
View user's profile Send private message
B Marcelly
Super User
Super User


Joined: 12 May 2004
Posts: 1453
Location: France

PostPosted: Thu Oct 05, 2006 10:05 am    Post subject: Re: Possible Bug with Dialog Organizer Reply with quote

DVezina wrote:
3. Use the Dialog Organizer to drag dialog to:
Untitled1/Standard/myInterface
(or really anywhere outside of "My Macros")

You have moved the dialog from My macros to your document (untitled).
DVezina wrote:

4. Exit document and discard changes - I had made other changes in my template that I did not wish to save.

* Dialog is missing - apparently deleted? Not in My Macros or Untitled.

The dialog was in your discarded document Embarassed
DVezina wrote:
I hope I didn't just lose 2 weeks of work.
Of course you have regularly done backups during these days Question
Back to top
View user's profile Send private message Visit poster's website
DVezina
OOo Advocate
OOo Advocate


Joined: 29 Sep 2006
Posts: 248
Location: Orlando

PostPosted: Thu Oct 05, 2006 10:36 am    Post subject: Reply with quote

Yes - Dialog is in discarded document. Embarassed I would have thought the dialog would have been moved back since I never saved the document template. That's how it works in Word.

My daily backups backup only user directories. Since I don't know exactly where the dialog in "My Macros" was stored, I don't know where to retrieve it from.

Backups of previous templates and documents do not contain the dialog.

If you can tell me where a dialog is stored when in "My Macros", that would be helpful. Software is installed in C:/Program Files/OpenOffice.org 2.0 (This directory is not backed up on a daily basis though.)

Thanks
Back to top
View user's profile Send private message
DVezina
OOo Advocate
OOo Advocate


Joined: 29 Sep 2006
Posts: 248
Location: Orlando

PostPosted: Thu Oct 05, 2006 1:39 pm    Post subject: Reply with quote

I'm posting the answer to my own question for those of you that need to know ...

For the PC the data is in:

C:\Documents and Settings\[User Name]\Application Data\OpenOffice.org 2.0\user\basic
Back to top
View user's profile Send private message
schwinn434
General User
General User


Joined: 18 Feb 2006
Posts: 47

PostPosted: Mon Jan 12, 2009 1:06 pm    Post subject: Lossing Macros (As Well) Reply with quote

Hello Everyone

I have lost two sets of macros I've recorded - using Tools/Macros/Record Macros. I lost them each time OO Calc. crashed - for various reasons.

After the first crash, I saved - using "Custom/Keyboard/Save" - the keyboard configuration to a file - so I could reload the keyboard configuration. However, the actual "mapping" of the keyboard seems to be recovered "properly" after each crash -- but not the macros, themselves, which are being pointed to. I also have tried to reload the keyboard configuration (using the saved keyboard configuration file I just mentioned), but OO Calc can't seem to find the macros which these saved keyboard configurations point to.

The first set of macros was saved under OpenOffice.org/user/Standard (I believe this is the location I saved them too) ; the second time around, I “know” I saved them under OpenOffice.org/Macros/Library1/Module1 (Library1 being a library I created - not very creative, I know.)

I haven't tried saving these recorded macros under the actual file I'm trying to use them with, i.e., OpenOffice.org/Macros/Run Schedule 2009/Standard - “Run Schedule 2009” being the actual document I want these macros to operate within.

I just realized that some of my macros are still present under: OpenOffice.org/Macros/Library1/Module1 ( I believe these macros were save “properly” when I
completely closed OO Calc.

Any help backing up these macros would be greatly appreciated.

Thanks
James "Jimmy" Lacy Kamuf
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group