OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Two languages, autodetect on / spellcheck not working

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
highwaykind
Newbie
Newbie


Joined: 27 Nov 2006
Posts: 1

PostPosted: Mon Nov 27, 2006 10:39 am    Post subject: Two languages, autodetect on / spellcheck not working Reply with quote

I am using OpenOffice since 4 days.
After it completely gave up on spell checking I re-installed it.
Whole window color/shape/icons look different so I must have a installed different version from the one that came with Kubuntu (the old one looked nicer.. Sad ) but at least spellcheck is somewhat working again.

That is, until I make a typo.
I type in English and Dutch.
Apparently there is no auto detection of the language?
Because when I make a typo in English it tried to correct me by suggesting Dutch words. Which is not really helping too much.

How do I fix this?

C.
_________________
Thank you for saving me the trouble of deflecting that personal question with a joke.
Back to top
View user's profile Send private message
foxcole
Super User
Super User


Joined: 19 Jan 2006
Posts: 2771
Location: Minneapolis, Minnesota

PostPosted: Mon Nov 27, 2006 11:55 am    Post subject: Reply with quote

Please try searching the forum. Many questions about spellcheck and languages have been asked and answered. You might also look in Writer's Help file. I'm not sure about your version, but in my 2.0.4 for Windows XP, the index has a "spellcheck" entry, and one of the topics under that is specific to your question.

Also, from what I remember reading in the forum, Kubuntu distributes its own version of OOo which I believe is not very stable, so it may very well be that you have a different version... but the new version might work better, overall. (But, please don't take my word for it. Perhaps you might want to search the forum for Kubuntu.)

Cheers!
_________________
Cheers!
---Fox

WinXP Pro SP2, OOo Portable 2.3.1, OOo local 2.4 RC4
New OpenOffice forum: http://user.services.openoffice.org/en/forum/
Manuals: http://documentation.openoffice.org/manuals/index.html
Back to top
View user's profile Send private message AIM Address Yahoo Messenger
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Mon Nov 27, 2006 12:20 pm    Post subject: Re: Two languages, autodetect on / spellcheck not working Reply with quote

highwaykind wrote:
I am using OpenOffice since 4 days.
After it completely gave up on spell checking I re-installed it.
Whole window color/shape/icons look different so I must have a installed different version from the one that came with Kubuntu (the old one looked nicer.. Sad ) but at least spellcheck is somewhat working again.

That is, until I make a typo.
I type in English and Dutch.
Apparently there is no auto detection of the language?
Because when I make a typo in English it tried to correct me by suggesting Dutch words. Which is not really helping too much.

How do I fix this?

C.


The language is a function of the paragraph style or the template that you are using. If you are writing in 2 languages in 1 document you need to set up paragraph styles in both languages.

If you are using the two languages in seperate documents the best idea is to set up 2 templates, one in English and 1 in Dutch.

Here are some general guidelines
You must make sure that you have the dictionaries you need. Go
Tools>Options>Languages Settings > Languages and see if the language you want has a check mark beside it. See this for an example http://ca.geocities.com/jrkrideau/images/Checkmark.jpg) Only languages with a checkmark are actually on your computer. If it is not there go to
File>Wizards>Install new dictionaries and follow the instructions from there.

Once the dictionary is downloaded quit OOo and Quickstarter, restart OOo and go Tools>Options>Languages Settings > Languages and select the language you want.

There are (AFAIK) three ways to set up for a language to be spell checked:.

1) For the entire document
Tools > Options>Language Settings> Languages which will make the default dictionary the language selected and all text in the doc will be assumed to be that language (at least for that document. There is an option on the Languages mask to set the dictionary only for the current document).

2)For a paragraph
Create a new paragraph style called Insert your own choice and assign the dictionary to it by setting the Language option under Font. Then use it to format the paragraph. You must format the paragraph before spell checking.

3) For a word or phrase:
Do the same as 2 but for a characters style : Use it to format individual words or phrases in an otherwise different language paragraph.
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Mon Nov 27, 2006 11:18 pm    Post subject: Reply with quote

foxcole wrote:
Kubuntu distributes its own version of OOo which I believe is not very stable, so it may very well be that you have a different version...

Right. Depending on the Ubuntu version it's not the same (in Dapper, it's 2.0.2 and Edgy it's 2.0.4). It seems there are some bugs with the Ubuntu packages of OOo (especially with menu icons) and I've seen somewhere that some features were disabled (like plug-in for Firefox, could you confirm ? if you've installed with APT ?). I only install OOo from the official RPMs and it works like a charm.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group