OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Can't save options (Issue filed)
Goto page 1, 2  Next
 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
gms
General User
General User


Joined: 13 Feb 2007
Posts: 8

PostPosted: Tue Feb 13, 2007 4:41 am    Post subject: Can't save options (Issue filed) Reply with quote

At Win XP, the OOo 2.1 can't keep the options of Language Settings -> Writing Aids. I keep checking the check boxes "Check uppercase words" and "Check in all language" but every time I restart OOo or I open an existing document those check boxes are empty and I have to check them again. Can I fix it ?

In case that is useful, I created a character style and I made a shortcut for it. I also have added a new default template.


Last edited by gms on Fri Feb 16, 2007 6:47 am; edited 1 time in total
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Thu Feb 15, 2007 1:23 pm    Post subject: Reply with quote

Try to rename the folder /Document and settings/<user>/Application data/openoffice.org2, OOo will create a new user profile.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
gms
General User
General User


Joined: 13 Feb 2007
Posts: 8

PostPosted: Thu Feb 15, 2007 3:17 pm    Post subject: Reply with quote

I didn't mention it, but I erased this folder already 2 times to make a new profile from the start. No use. I have the same problem with the computer I use at work, only that this one it also unchecks the option for the autosave recovery information.

At first I had disable the Quickstarter option but now I enable it again because this way it lose the Language settings only when I restart or turn off the computer.

Also, I erased the extra dictionaries because after every restart I had to uncheck again all the unnecessary dictionaries...
Back to top
View user's profile Send private message
noranthon
Super User
Super User


Joined: 07 Jul 2005
Posts: 3318

PostPosted: Thu Feb 15, 2007 5:54 pm    Post subject: Reply with quote

It sounds as though the settings you make are being overwritten. That rings a bell but I can't find the bell.

It also sounds like a bug.
_________________
search forum by month
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Thu Feb 15, 2007 11:20 pm    Post subject: Reply with quote

Have you read/write rights on all the files in folders and subfolders of the OOo user profile folder ?

Have you any application like anti-spyware/CCleaner that could take OOo as nasty code and removes its settings ?
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
noranthon
Super User
Super User


Joined: 07 Jul 2005
Posts: 3318

PostPosted: Fri Feb 16, 2007 3:38 am    Post subject: Reply with quote

I know I have looked this up for someone else. When I changed a setting in >Language Settings >Writing Aids just now, the following 3 files changed:
~/.openoffice.org2/user/registry/data/org/openoffice/Office/
Linguistic.xcu. Calc.xcu and Common.xcu

Your settings are being changed properly but one of those files (probably the first) is not surviving the re-launch of OpenOffice.

The first file is mentioned in 13 posts on this sub-forum. Hagar de l'Est may recall this. I have the impression that there is some problem with the file being overwritten because of some system file, possibly a file by the same name.
_________________
search forum by month
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Fri Feb 16, 2007 4:42 am    Post subject: Reply with quote

In fact, the file linguistic.xcu can cause problems when you install a language pack (to change the language UI : menus and dialogs) and additional dictionaries through the wizard.

But perhaps there is something else that can lead to the same issue. Try to remove this file (in \Documents and Settings\<user>\Application data\OpenOffice.org2\user\registry\data\org\openoffice\Office).

NB: to remove the dictionnaries you don't want, you've to edit some configuration file, see here : [Tutorial] Spell check.

[Edit] There is also this linguistic.xcu file in C:\Program Files\OpenOffice.org 2.0\share\registry\data\org\openoffice\Office, try to remove this one also. I think OOo replaces the one in your user profile by this one.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
gms
General User
General User


Joined: 13 Feb 2007
Posts: 8

PostPosted: Fri Feb 16, 2007 6:46 am    Post subject: Reply with quote

Hagar de l'Est wrote:
In fact, the file linguistic.xcu can cause problems when you install a language pack (to change the language UI : menus and dialogs) and additional dictionaries through the wizard.

But perhaps there is something else that can lead to the same issue. Try to remove this file (in \Documents and Settings\<user>\Application data\OpenOffice.org2\user\registry\data\org\openoffice\Office).

NB: to remove the dictionnaries you don't want, you've to edit some configuration file, see here : [Tutorial] Spell check.

[Edit] There is also this linguistic.xcu file in C:\Program Files\OpenOffice.org 2.0\share\registry\data\org\openoffice\Office, try to remove this one also. I think OOo replaces the one in your user profile by this one.



Solved !!!!

I deleted the file linguistic.xcu from those folder plus the backup file linguistic.xcu.bak from the first folder. Now OOo remembers the settings....

Thank you !!
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Fri Feb 16, 2007 6:52 am    Post subject: Reply with quote

Great ! thanks to noranthon who pointed the right root cause.

Thanks to add '[Solved]' in your first post title (edit button) if it's ok.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
noranthon
Super User
Super User


Joined: 07 Jul 2005
Posts: 3318

PostPosted: Fri Feb 16, 2007 4:54 pm    Post subject: Reply with quote

These things ought not to be. Has anyone filed an issue? (I took the liberty of adding the question to the thread title.)
_________________
search forum by month
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Fri Feb 16, 2007 11:11 pm    Post subject: Reply with quote

Yes, I'd filed this report : Issue 72957 - User settings overridden by installation.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
noranthon
Super User
Super User


Joined: 07 Jul 2005
Posts: 3318

PostPosted: Sat Feb 17, 2007 3:29 am    Post subject: Reply with quote

Thanks, Hagar de l'Est. I think it's appropriate to show that in the thread title so that people are aware that the subject involves a software issue.
_________________
search forum by month
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Sat Feb 17, 2007 1:31 pm    Post subject: Reply with quote

gms, can you remember if you made any special operation just before this happened ? It could help finding a pattern for this issue. Have installed any language pack or dictionary, ... ?
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
gms
General User
General User


Joined: 13 Feb 2007
Posts: 8

PostPosted: Mon Feb 19, 2007 3:43 pm    Post subject: Reply with quote

I want to thank you both Smile


Yes, I installed the Greek dictionary and I set a custom template as default.

The template sets the line spacing at 130% proportional and installs a new character style in English language. I also made 3 shortcuts, one for applying the default character style in Greek, one for applying the English character style (to choose quickly the proper dictionary) and one more for word count. Finally, I created a user-defined dictionary.
The problem reappeared when I upgraded to OOo 2.2 rc1 but it solved again with the method you told me. This time, I installed only the Greek dictionaries (the rest settings wasn't changed from the upgrade)

I made the same arrangements at Ubuntu 6.10 without problem. By the way, the Ubuntu version of OOo (2.04) has bugs, mostly at font smoothing witch doesn't work as it says. I finally manage to install the official 2.1 and I saw a different program...
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Tue Feb 20, 2007 2:12 am    Post subject: Reply with quote

gms wrote:
I installed the Greek dictionary

That's what I was waiting for. I'll add this thread to the bug comments.

gms wrote:
I made the same arrangements at Ubuntu 6.10 without problem.

That's interesting. It seems to be specific to Windows !

NB: I fully agree with you for the Ubuntu packages, I never use them but install from the official RPMs.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group