OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Trouble with Chinese Input/Display ONLY in Writer
Goto page 1, 2  Next
 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
tbbx
General User
General User


Joined: 30 Mar 2007
Posts: 7

PostPosted: Fri Mar 30, 2007 9:53 pm    Post subject: Trouble with Chinese Input/Display ONLY in Writer Reply with quote

Hi,

Here's my problem--when I enter multi-character words sometime the second character doesn't show up in the document. Also, any characters after that do not show up. But the characters are in the document.

I'm running a Chinese installation of XPSP2. I have the Microsoft IME installed and can input Chinese characters with no problem in MS-Office and in OOCalc.

If I type, "niyoushenmewenti' in Writer, I see this: 你有什?(missing 3 characters-everything after the first multi-character word "shenme'")

But if I copy and paste from Writer into Calc or MS-Word, I see this: 你有什么问题?(it's correct)

It seems that the trouble happens when the IME needs to choose the second character.

If I type"beijingshanghai", I see this: 北京上海 (it's correct)

If I type"beijingchangcheng", I see this: 北京城 (it's missing the a character, #3)
If I cut and paste the characters above from Writer into Calc, I see this: 北京长城 (it's correct)

So, it seems that the characters are there, but not visible.

Any suggestions?
_________________
Thanks,

TBBX
Back to top
View user's profile Send private message
Robert Tucker
Moderator
Moderator


Joined: 16 Aug 2004
Posts: 3407
Location: Manchester UK

PostPosted: Fri Mar 30, 2007 11:09 pm    Post subject: Reply with quote

Are you using the same font in Writer as elsewhere? Which input method are you using? Have you tried others? What happens if you try to input "me", "wen" and "ti" individually?

I did try "niyoushenmewenti" on Linux/SCIM and there was no problem.

(Trying "beijingshanghai" - typing "jing" with py IM did not give the option of 京)
Back to top
View user's profile Send private message
tbbx
General User
General User


Joined: 30 Mar 2007
Posts: 7

PostPosted: Sun Apr 01, 2007 10:06 pm    Post subject: Reply with quote

Thanks for your help.

I'm not sure how to answer your question about which IME I'm using. My PC has a Chinese version of WinXP, so It' tough for me to get tech info. I believe that it is the IME built into XP.

The font seems to be the key. The problem is a display problem and not an input problem.

If I use Arial in Writer, I have the problems seeing the second character in come words. This includes things I type as well as things pasted into Writer.

For pasted words with multiple characters, if I see only 1 character, I can backspace and then hit [space] and see the other character.

I thought I was using the same font in Calc (Arial), but I noticed that when I type in Chinese, Calc changes the font to SimSun automatically.

Other fonts have this problem as well - Times New Roman, Bookman Old Style, Garamond, etc. Batang works just fine, as do the Chinese fonts.

The problem now is that the Chinese fonts look great for Chinese, but lousy for English since they are set up to be evenly spaced. English looks too spread out.

Does anyone have any suggestions for a font?
_________________
Thanks,

TBBX
Back to top
View user's profile Send private message
Robert Tucker
Moderator
Moderator


Joined: 16 Aug 2004
Posts: 3407
Location: Manchester UK

PostPosted: Mon Apr 02, 2007 12:26 am    Post subject: Reply with quote

Neither the Arial font nor the Times New Roman font (nor probably Bookman Old Style or Garamond) contain Chinese characters. OpenOffice must be inserting Chinese characters from a different font. Perhaps the problem is there.

Arial Unicode MS does contain Chinese characters (as does Code2000) so you should be able to type in both Chinese and English with them with no problem (as long as you find them visually tolerable). Of course, you could use one font for Chinese and another for English if you set them as styles you will then not have problems spellchecking.
Back to top
View user's profile Send private message
hwtan
OOo Advocate
OOo Advocate


Joined: 24 Aug 2004
Posts: 320
Location: Singapore

PostPosted: Mon Apr 02, 2007 12:36 am    Post subject: Reply with quote

Indeed, those missing words are different in the traditional and simplified form. Thus, I think the IME is set to traditional Chinese and yet the font is a simplified Chinese font and that explains the missing characters. Therefore, to make sure that my guess is correct, change the font to one that is traditional or contain traditional characters like MSHei or Simsun. All characters should appear but only in traditional Chinese. If that is the case, just set the IME to simplified Chinese and that should take care of it. It is not the fault of OO writer.

Have joy.
Back to top
View user's profile Send private message
Robert Tucker
Moderator
Moderator


Joined: 16 Aug 2004
Posts: 3407
Location: Manchester UK

PostPosted: Mon Apr 02, 2007 1:52 am    Post subject: Reply with quote

(I can confirm that I can input all the above characters with the SCIM Smart Pinyin and Code2000 font on Linux.)
Back to top
View user's profile Send private message
tbbx
General User
General User


Joined: 30 Mar 2007
Posts: 7

PostPosted: Mon Apr 02, 2007 3:58 am    Post subject: Reply with quote

I checked--the IME is set for simplified Chinese. I am living in the People's Republic and it's all about simplifying here.

I'm looking into the Unicode fonts you suggested. Thanks.

One thing I don't quite understand. Why do you think I have no troubles doing this in MS-Word, Excel, Notepad, in email and blogging (using Firefox), but have trouble with Writer?
_________________
Thanks,

TBBX
Back to top
View user's profile Send private message
Robert Tucker
Moderator
Moderator


Joined: 16 Aug 2004
Posts: 3407
Location: Manchester UK

PostPosted: Mon Apr 02, 2007 4:19 am    Post subject: Reply with quote

tbbx wrote:

One thing I don't quite understand. Why do you think I have no troubles doing this in MS-Word, Excel, Notepad, in email and blogging (using Firefox), but have trouble with Writer?


Two possibilities I know of:

1) The font could easily be set to something different to Writer in the others

2) OpenOffice has its own font rendering system

For simplified Chinese Unicode fonts see:

www.alanwood.net/unicode/fonts.html#simplified
www.wazu.jp/gallery/Fonts_ChineseSimplified.html
Back to top
View user's profile Send private message
tbbx
General User
General User


Joined: 30 Mar 2007
Posts: 7

PostPosted: Mon Apr 02, 2007 4:43 am    Post subject: Reply with quote

OK, this is strange.

I installed Code2000, XSerif, and Lucida San Unicode (which had already been on the system), then re-booted. When I opened Writer, I could use any font to enter Chinese and English. Writer seems to be using Simsun for all the Chinese unless the font I choose contains Chinese characters.

When I change the font, the Chinese usually did not change in appearance, but the English does.

My old problem of characters not displaying on the screen (but being the document) went away.

I'm not sure how this happened, but I'm happy it works now.
_________________
Thanks,

TBBX
Back to top
View user's profile Send private message
Robert Tucker
Moderator
Moderator


Joined: 16 Aug 2004
Posts: 3407
Location: Manchester UK

PostPosted: Mon Apr 02, 2007 5:19 am    Post subject: Reply with quote

If you go to:

Tools>Options...>OpenOffice.org Writer>Basic Fonts (Asian)

you will probably find that Simsun is the font listed there.
Back to top
View user's profile Send private message
hwtan
OOo Advocate
OOo Advocate


Joined: 24 Aug 2004
Posts: 320
Location: Singapore

PostPosted: Mon Apr 02, 2007 5:00 pm    Post subject: Reply with quote

Yes, I agree with Tucker, I think the default Asian font is set to one that is traditional. Btw, not all unicode fonts contain all the code page, that is to say not all contain Chinese characters. Arial Unicode MS, MSHei, MSSong are good sets to start with.
Back to top
View user's profile Send private message
tbbx
General User
General User


Joined: 30 Mar 2007
Posts: 7

PostPosted: Mon Apr 02, 2007 6:59 pm    Post subject: Reply with quote

The Default Asian font is listed as Arial.

In the IME panel I can choose several ways to enter the characters (3 pinyin methods or stroke order), but all of them input 健体 , or simplified characters.
_________________
Thanks,

TBBX
Back to top
View user's profile Send private message
hwtan
OOo Advocate
OOo Advocate


Joined: 24 Aug 2004
Posts: 320
Location: Singapore

PostPosted: Mon Apr 02, 2007 7:11 pm    Post subject: Reply with quote

Arial by itself does not contain Unicode font. So, OOo writer will substitute it with whatever is set by your system. Therefore, you need to change this default setting with a simplified font or a full set of Chinese Unicode font (eg, the Arial Unicode MS, or MSHei). Or try the kaiti in this link, http://www.freedesktop.org/wiki/Software_2fCJKUnifonts_2fDownload.
Back to top
View user's profile Send private message
tbbx
General User
General User


Joined: 30 Mar 2007
Posts: 7

PostPosted: Mon Apr 02, 2007 8:03 pm    Post subject: Reply with quote

That makes sense it Arial simply doesn't have CJK characters.

Can you tell me where can I find the default setting on the system? (WinXP)
_________________
Thanks,

TBBX
Back to top
View user's profile Send private message
hwtan
OOo Advocate
OOo Advocate


Joined: 24 Aug 2004
Posts: 320
Location: Singapore

PostPosted: Mon Apr 02, 2007 8:08 pm    Post subject: Reply with quote

Quote:
Can you tell me where can I find the default setting on the system? (WinXP)


Sorry I have no idea about this. My suggestion is that you change setting in OOWriter. If you need any font that I mentioned earlier on, do a search in the Internet and you should be able to find them.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group