OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Report Wizard

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base
View previous topic :: View next topic  
Author Message
John Gregson
General User
General User


Joined: 26 Sep 2006
Posts: 16
Location: Canada

PostPosted: Sun Apr 01, 2007 9:02 am    Post subject: Report Wizard Reply with quote

I am using Open office 2.2; Windows version.
I have a Table with 13854 records; 12 fields per record.

When I start the Report Wizard, it says that it has imported 13850 records; then it seems to lock up.
I waited for quite a while to see if the pgm would complete, but to no avail.

I noticed on the Writer screen, where it had me as the author, which is O.K., but for the Date is had "4/26/02"; (without the quotes).

Is the report generator limited to a small number of records?

Later, I tried using the Report Wizard on a much smaller database, 74 records.
Same thing happened.

In both cases, I noticed that on the Writer screen that the column widths were incorrect, by a large amount..

Any comments or suggestions.

I have used MS Access and MS Works in the past.

John.
_________________
jfgregson@shaw.ca
Canada
Back to top
View user's profile Send private message
DrewJensen
Super User
Super User


Joined: 06 Jul 2005
Posts: 2616
Location: Cumberland, MD

PostPosted: Sun Apr 01, 2007 10:49 am    Post subject: Reply with quote

At this point all I have is a few comments.

I took an embedded Base file I have with BaseBall stats in it - my tourcher test for Base.

Created a query that returned 4 fields ( ID, LastName, FirstName, DeathYear ) from the players table. I limited this query result to the first 1000 records and then ran the report wizard against this. Not real fast, but it was not too terribly bad.

I then kicked it up to the first 10,000 records - wow - big difference.

Now, on my machine AMD64, WinXp OOo 2.2 it does run to completion - all 323 pages of report - but it takes it a very long time. Interestingly if I change the priority on the process soffice.bin to LOW the report manager seems to run faster, not really sure what that is all about except that this frees up CPU cycles for other processes and perhaps soffice is using kernal routines that needed those cycles ( memory allocation perhaps )

Oh, yes - I notice the date is 4/26/02 on the report.

OK so what was a long time - around 3.5 minutes to get the report finished for 10,000 records. Doesn't sound like a lot, unless you are sitting staring at a nearly blank screen - and with soffice.bin running with a normal priority the machine was virtually frozen for that whole time.

Not sure what to tell you that could help - for now I am off to kick that query up to 15,000 records and see if it is a linear increase in time or worse.

I'll be passing along your comments and some of my own on this to the Base developers on the OO.o mailing list in the morning - so if I hear anything constuctive I'll post it back up here.
_________________
Blog - http://baseanswers.spaces.live.com/
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group