OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Database freezes pc

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base
View previous topic :: View next topic  
Author Message
hedgerowbackwards
General User
General User


Joined: 10 Mar 2006
Posts: 8

PostPosted: Fri Mar 10, 2006 8:40 am    Post subject: Database freezes pc Reply with quote

If I create a new database I get to the the screen with Tables/Queries/Forms/Reports down the left edge and the message 'HSQL database engine' on the bottom bar. Selecting Tables (or Queries/Forms/Reports ) then freezes the pc - can't even call up the task manager with ctl-alt-del - and the only option is to crash the system.

This problem, has been in existence through v2.0.0, v2.0.1 and now 2.0.2. I run Winxp and Open Office is Java enabled.

Help appreciated, HRB.
Back to top
View user's profile Send private message
DrewJensen
Super User
Super User


Joined: 06 Jul 2005
Posts: 2616
Location: Cumberland, MD

PostPosted: Fri Mar 10, 2006 9:00 am    Post subject: Reply with quote

well, given that it happens when you try to connect (Opening the base document does create the connection until you select the table view, or open a form that is attached to a table) I would guess it is the JRE that is having a problem.

Which version of the JRE are you, using. Also a few people in the past have reported similar problems and in, I think, those cases they needed to remove and then re-install the JRE. This took care of their problem.
_________________
Blog - http://baseanswers.spaces.live.com/
Back to top
View user's profile Send private message Send e-mail Visit poster's website
hedgerowbackwards
General User
General User


Joined: 10 Mar 2006
Posts: 8

PostPosted: Fri Mar 10, 2006 9:16 am    Post subject: Reply with quote

Yes, I saw the posyt in another thread and started looking at the java aspect.

I downloaded and installed the java version. I now have 3 versions of java in program files/java , the latest version being jre.5.0_6 downloaded with OO 2.0.2 today. However, when I go into Tools/options/java, even from writer, the system freezes. The check box 'Use Java' is checked but no Java run times are shown in the table. And because the system is frozen I can neither uncheck the box nor Add a runtime.

Does this mean downloading a non-java version?

Regards, hrb.
Back to top
View user's profile Send private message
DrewJensen
Super User
Super User


Joined: 06 Jul 2005
Posts: 2616
Location: Cumberland, MD

PostPosted: Fri Mar 10, 2006 9:35 am    Post subject: Reply with quote

I don't know, I have the same setup as you..WinXP, and I have never had it freeze like that. I have had it crash, but not freeze the OS.

If you run other Java applications do they do so without any problems.
_________________
Blog - http://baseanswers.spaces.live.com/
Back to top
View user's profile Send private message Send e-mail Visit poster's website
hedgerowbackwards
General User
General User


Joined: 10 Mar 2006
Posts: 8

PostPosted: Sat Mar 11, 2006 1:45 am    Post subject: Reply with quote

Yes java works ok in other apps.

The latest attempt was:
Remove open office program in control panel, delete folders - program files/open office, documents & settings/appdata/open office and the unpack folder - download and clean install the non-java version of open office.

Result: Tools/options/java still shows 'use java' checked and no installed java packages. The system freezes completely - though I think that this must be an endless loop - and the system has to be crashed and rebooted.

Any help would be very welcome.
Back to top
View user's profile Send private message
uldics2
Newbie
Newbie


Joined: 11 May 2007
Posts: 1

PostPosted: Fri May 11, 2007 1:16 am    Post subject: Reply with quote

I have same problem with Debian Etch.
Java is: Sun Java(TM) Runtime Environment (JRE) 5.0 version 1.5.0-10-3
Java is working with other applications (Azureus) and applets in web pages (in Opera).

When I start Base, open or create a database file (without registering it on net), it stays on Forms. Everything is active and working. As soon as I choose Querries, Tables, Forms or anything else - OOo freezes. I can minimise and get back to screen (only a thin frame comes up with anything what was under it - frozen inside the frame). Nothing works anymore. The onlything to do is kill the .bin process.


Looks like I sorted it out. In settings, the Java was set to be used, but wasn't chosen which java to use. So I selected the only one I had and now it is not freezing anymore.
Back to top
View user's profile Send private message
DrewJensen
Super User
Super User


Joined: 06 Jul 2005
Posts: 2616
Location: Cumberland, MD

PostPosted: Fri May 18, 2007 7:08 am    Post subject: Reply with quote

Big delay in getting back here - sorry

Glad you got it worked out - actually that should go in o the Issue tracking system, as an Installation issue. OOo should have recognized the JRE on your system when it was installed and automatically selected the most current.

The only time you should have to work the the Java settings directly is when adding additional components in the Classpath, or choosing a different JRE when you have multiple installed - for example, telling Base where to find JDBC drivers for a specific server based database.
_________________
Blog - http://baseanswers.spaces.live.com/
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group