OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Font Trouble

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
ishinji32
Newbie
Newbie


Joined: 25 Aug 2007
Posts: 3

PostPosted: Sat Aug 25, 2007 1:10 pm    Post subject: Font Trouble Reply with quote

I recently installed the official OpenOffice on Kubuntu 7.04 since the version from the repositories would crash with some glib error every time it ran. Now I am running into trouble as far as fonts are concerned. Math, Impress, Base, Draw, and Printer Administration will start, but Writer and Calc crash at startup. As well, if I try to manipulate fonts in any way OpenOffice immediately crashes (going into the Fonts heading in Tools -> Options, using the Text tool in Impress, trying to rename a font in Printer Admin, etc).

Not sure what's going on here. Help!
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Sun Aug 26, 2007 12:39 am    Post subject: Reply with quote

How many fonts have you ? It has been reported that if you've too many of them (more than 500 or 1000, don't remember exactly the limit), it could lead to some problems.

What procedure have you followed to install the official version ?
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
ishinji32
Newbie
Newbie


Joined: 25 Aug 2007
Posts: 3

PostPosted: Sun Aug 26, 2007 2:06 am    Post subject: Reply with quote

I only have what came with Kubuntu, I'm not sure what I could use to get an exact count but the list in AbiWord is definitely less than 500.

To install, I downloaded the official release, converted the RPMs to .deb with alien, then installed with sudo dpkg -i *.deb, afterwards installing the debian desktop-integration .deb with dpkg.
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Sun Aug 26, 2007 2:17 am    Post subject: Reply with quote

When converting with alien, have you put the "--scripts" parameter ?
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
ishinji32
Newbie
Newbie


Joined: 25 Aug 2007
Posts: 3

PostPosted: Sun Aug 26, 2007 10:13 am    Post subject: Reply with quote

Yes.
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Sun Aug 26, 2007 10:50 am    Post subject: Reply with quote

You could try first to rename your OOo user profile (~/.openoffice.org2) to see if a new profile improves the situation.

Else, you can try to see if the problem comes from a specific font file (perhaps because of renaming it). Move half of the fonts in another place and see if it still crash, try with the other half and so on until you spot the damaged font file.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group