OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

pyuno: HELP... registry doesn't always work.

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Macros and API
View previous topic :: View next topic  
Author Message
chrisj0
General User
General User


Joined: 03 Apr 2003
Posts: 7
Location: Chicago, IL

PostPosted: Thu Apr 03, 2003 10:55 am    Post subject: pyuno: HELP... registry doesn't always work. Reply with quote

Hi all,
I'm trying to start to work with the Python-UNO bridge 0.9.3. The first day of working with the installation program and examples work great. I wrote a bash script which replaces the tcsh script pyunoenv.tcsh and pyuno_setup.sh. Everything worked fine.
I come back to work and the same thing now dosen't work. I can't get the pyuno modules to register properly. I get the error:

register component 'pycpld' in registry 'services.rdb' succesful!
register component 'vnd.openoffice.pymodule:swritercomp' in registry 'services.rdb' failed!
error (RuntimeException): pyuno: couldn't instantiate invocation service

The troubleshooting section of the python-bridge.html document doesn't give any helpfull information. I'm kinda stuck. Any pointers in the right direction would be helpfull.
thanks,
chrisj Confused
Back to top
View user's profile Send private message
chrisj0
General User
General User


Joined: 03 Apr 2003
Posts: 7
Location: Chicago, IL

PostPosted: Thu Apr 03, 2003 12:03 pm    Post subject: Reinstall and it worked. Reply with quote

Ok I reinstalled the OpenOffice.org1.1Beta. and Python UNO bridge and it worked again.
I'm not sure why. I'd like to avoid this problem in the future though. If any one knows what it may have been please post a reply.

I'm using RH linux 7.2, OpenOffice1.1Beta, and Python UNO bridge 0.9.3....

thanks again.
chrisj Confused Exclamation Exclamation
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Macros and API All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group