OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Please help! How do I disable or turn off drag and drop?

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
yosemiteg
Newbie
Newbie


Joined: 16 Jan 2008
Posts: 2

PostPosted: Wed Jan 16, 2008 2:36 pm    Post subject: Please help! How do I disable or turn off drag and drop? Reply with quote

I know that the drag and drop feature is very useful and users love it, but it drives me crazy. One of the first things I do in Msoft is turn off this feature.

Is there a way to disable it in OpenOffice?

Thanks,
Gina
Back to top
View user's profile Send private message
Fundi
OOo Advocate
OOo Advocate


Joined: 21 Sep 2004
Posts: 278

PostPosted: Wed Jan 16, 2008 3:51 pm    Post subject: Reply with quote

I'm not sure I get what your problem is.

Drag and drop is a Operating system feature. That application programs support. I'm not sure it can be switched of.

But if you don't want to use it just don't drag anything. After all it is a concious decision to highlight something and then keep the mouse button down while dragging across.

MJ
Back to top
View user's profile Send private message
yosemiteg
Newbie
Newbie


Joined: 16 Jan 2008
Posts: 2

PostPosted: Wed Jan 16, 2008 4:10 pm    Post subject: Reply with quote

Hi, thanks for the reply. In Msoft, you could uncheck a box in the options menu, so the feature would be turned off.

Unfortunately, I seem to activate drag and drop everytime I just try to select text, etc. It's not very deliberate for me.

Anyone else have any ideas?
Back to top
View user's profile Send private message
TRUETYPIST
General User
General User


Joined: 25 Oct 2006
Posts: 47

PostPosted: Wed Jan 16, 2008 6:29 pm    Post subject: Reply with quote

Do you have some type of disability ?
Maybe your Mouse configuration is inadequate: On the control panel, check:
Mouse > Buttons > Double-Click and ClickLock settings.
Back to top
View user's profile Send private message
huwg
Super User
Super User


Joined: 14 Feb 2007
Posts: 890

PostPosted: Thu Jan 17, 2008 1:06 am    Post subject: Reply with quote

I sometimes have this problem in Calc. It usually happens when I select some text but don't get the exact bit I want, so I try to change the selection - sometimes the previous selection won't deselect, or it sometimes appears to (temporarily de-highlights) but actually doesn't. The end result is that when I drag the cursor to make the new selection, the old one is moved instead. To overcome this, before I start throwing things, I usually exit the cell and return.

It's not something I can replicate, but it happens often enough, and has done so over a long enough time, that I know it's real. I've used drag & drop to rearrange text for years so maybe it's something instinctive I do that works in other applications, but not OpenOffice.

I don't use Writer enough to have noticed the problem there, but I'd expect the same text selection code is used by both.*

The only odd result I got in my efforts to replicate this just now was a couple of times Escape did not fully cancel an initiated but unfinished drag & drop - it just deselected the highlighted text and left me with a cursor indicating I was still carrying a clipping. Dropping the clipping did not result in any text moving or appearing.

All that said, if you are constantly having problems, maybe your mouse is set up oddly.

Edit: Maybe it isn't - in Calc double-click selecting a word followed by drag doesn't select text word by word as in Writer, it just selects the initial word and won't extend.


Last edited by huwg on Mon Jan 21, 2008 12:50 am; edited 1 time in total
Back to top
View user's profile Send private message
Fundi
OOo Advocate
OOo Advocate


Joined: 21 Sep 2004
Posts: 278

PostPosted: Fri Jan 18, 2008 9:20 am    Post subject: Reply with quote

it is still quite difficult to understnd the exact problem you have. But aim trying.

1. Where could you switch of drag and drop in Micro$oft. Micro$oft is at best a company with a ton of products. Are you referring to their OS or an application. Well I presume it is an application since you compare it to OO.org. but which one and where could you switch that of.

2. Selection in Writer and Calc work slightly different due to the nature of the programs.
a) Writer will select text sequentially calc selects by cell (unless you double click a cell and then it selects in the cell only)
b) By pressing Ctrl between selections you can make more then one selection. This works in writer and in calc.

3. perhaps you need to change the strategy by which you select.
Try this: put the insertion point (the flashing bit) at the beginning from where you want to select. Then hold down shift while clinking where you want to end your selection. It will select everything in between. No dragging needed.

Then press Ctrl-C to copy or Ctrl-X to cut.
Then move the insertion point to where you want to have what you just copied then press Ctrl-v to paste.

No dragging and drooping needed.
Well I hope you are not throwing things again

MJ
Back to top
View user's profile Send private message
BillP
Super User
Super User


Joined: 07 Jan 2006
Posts: 2703

PostPosted: Fri Jan 18, 2008 11:57 am    Post subject: Reply with quote

Fundi wrote:
1. Where could you switch of drag and drop in Micro$oft. Micro$oft is at best a company with a ton of products. Are you referring to their OS or an application. Well I presume it is an application since you compare it to OO.org. but which one and where could you switch that of.


In Word 2000: Tools > Options > Edit > Editing options > Drag-and-drop text editing

There is an enhancement request for this option: Add option to turn off drag-and-drop editing
Back to top
View user's profile Send private message
Jack Raymer
Newbie
Newbie


Joined: 02 Mar 2008
Posts: 1

PostPosted: Sun Mar 02, 2008 5:39 pm    Post subject: Reply with quote

I have this same problem and would like very much to disable drag and drop editing, especially in Calc, but also in other programs.
I alway disabled it in Word and Excel. It was a check box in one of the Options dialog boxes.

The problem is that I am not as dextrous as some people end up accidently moving cells or blocks of text around.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group