OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Numbers are turned into dates...

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc
View previous topic :: View next topic  
Author Message
jakkan
General User
General User


Joined: 27 Mar 2008
Posts: 7

PostPosted: Sun Mar 30, 2008 5:09 am    Post subject: Numbers are turned into dates... Reply with quote

I paste a bunch of numbers into OO. Some of these numbers are automatically turned into dates. I don't want them to be dates. I want them to be ordinary numbers. So I format them to normal numbers, but now what was -1.44 has turned into 39544.

I don't know how to fix this. Please, how can I make it so the numbers are not automatically formatted into dates?

Big Thanks!
Back to top
View user's profile Send private message
Villeroy
Super User
Super User


Joined: 04 Oct 2004
Posts: 10106
Location: Germany

PostPosted: Sun Mar 30, 2008 5:35 am    Post subject: Reply with quote

You are working with a comma locale by default and you try to paste dotted decimals. What happens should be exactly the same as when you type the values into cells.
At least 3 options:
- Paste special as unformatted text and specify how to interprete each column (right-click column in preview)
- Apply some English number format locale to the target cells (mind US dates).
- Set the application locale temporarily in Tools>Options>LanguageSettings>Languages
_________________
Rest in peace, oooforum.org
Get help on https://forum.openoffice.org
Back to top
View user's profile Send private message
jakkan
General User
General User


Joined: 27 Mar 2008
Posts: 7

PostPosted: Sun Mar 30, 2008 6:12 am    Post subject: Reply with quote

What would the 21st century be without anonymous superheroes online? Big thanks Villeroy!
Back to top
View user's profile Send private message
jakkan
General User
General User


Joined: 27 Mar 2008
Posts: 7

PostPosted: Mon Apr 07, 2008 12:17 pm    Post subject: Reply with quote

I have a new similar problem :-/

5-12 is turned into 05/12/08. I have already set the language to English so that doesn't seem to cut it for this problem. How do I stop OO from turning 5-12 into a date?

Thanks!
Back to top
View user's profile Send private message
Villeroy
Super User
Super User


Joined: 04 Oct 2004
Posts: 10106
Location: Germany

PostPosted: Mon Apr 07, 2008 12:26 pm    Post subject: Reply with quote

If you don't want "5-12" to be a shortcut to 5th of december, what else should it be? A text? Then enter or import as text with a preceeding single quote. Number fomatting will not change any existing value, but you can turn off all number and formula recognition for newly entered/imported values by means of number format "Text".
_________________
Rest in peace, oooforum.org
Get help on https://forum.openoffice.org
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group