OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Unlocking a read only document
Goto page 1, 2  Next
 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
mike_sp
General User
General User


Joined: 19 Aug 2008
Posts: 5

PostPosted: Tue Aug 19, 2008 8:40 am    Post subject: Unlocking a read only document Reply with quote

Hello,

I worked on a new Open Office Write (2.4) document all day yesterday.
At the end of the day I did a final save and exited the document.
Today the document is read only.

1) Why did this happen?
Near the end of the day, I added a Table of Contents but was unable to make the index entries "hyperlinked" (for lack of a better term) so that the user could click on the index entry and navigate through the document. My suspicion is that the effort of adding/deleting the Table of Contents multiple times may have contributed to this problem.

2) How can I "unlock" it?
Since I don't know for sure why it happened, all that I really need to know is how to unlock it. The external properties box of the document, does not show the document as being "read only" so that was not an option. The internal properites box does not have anything relating to this attribute.
I have seen references on the Internet to using the "Edit File" toolbar button, but have been unable to get that to work. Yeah, in the posts it sound real easy - but it did not work for this document. Also, simply using SAVE AS does not work either.

3) I was able to resolve this by using MS Word, but this kind of defeats the pupose of using Open Office, don't you think? In MS Word, the area above the Table of Contents that I added with OO Write was protected, but the rest of the document was not. Once I deleted the TOC and the extra section breaks (added by OO Write?) and readded the TOC, I saved the document and was able to continue processing with OO Write.

Any help in providing an Open Office Write solution to this would be greatly appreciated.

Thanks,

Mike
Back to top
View user's profile Send private message
craigp01
Newbie
Newbie


Joined: 13 Jan 2009
Posts: 2

PostPosted: Tue Jan 13, 2009 5:27 am    Post subject: Reply with quote

I've run into the same problem, except it happened in version 3 running on a fully patched XP system. Tried several ways out, including:

1) Copy contents of the document into the paste buffer, then paste the contents into a new document. New document becomes read-only.

2) Experiment with "Edit File" button up in the menu bar. No change.

3) Copy the file into a new directory and edit it from there. No change. Document is still read-only.

Document is not password-protected.

Other documents in the same directory can be edited and saved without becoming subsequently read-only.

There are .lock files in the directory where the document is located.

The directory in question has no attributes that would trigger this behavior.

The people using this system wouldn't know how intentionally to accomplish what's going on here even if their lives depended on it.

My solution was to back rev to 2.4.2.

Another thing that worked was to export the document to .doc. Subsequently the file could be edited.

This is just FYI. Wish I could provide more/better info, and I wish I could have "sandboxed" the problem, but this happened on a production system and the need was urgent to get things back to normal.
Back to top
View user's profile Send private message
Bug
OOo Advocate
OOo Advocate


Joined: 29 Oct 2005
Posts: 336

PostPosted: Tue Jan 13, 2009 5:41 am    Post subject: Reply with quote

There's a button on the toolbar between the e-mail and PDF buttons. It looks like a paper with a pencil on top. Click this button to change a document from read-only to an editable document. This should work. If it doesn't, then say what happens when you try.
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Tue Jan 13, 2009 6:20 am    Post subject: Reply with quote

Annoying, but not normal behaviour.. You can try Options - OpenOffice.org - Security and note the status of the check boxes at the bottom; is Open this file in read-only mode checked?

If your problem has been solved, please edit the first post of this thread (Edit button) and add [Solved] to the start of the subject line.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
thomasjk
Super User
Super User


Joined: 16 Dec 2005
Posts: 2374

PostPosted: Tue Jan 13, 2009 6:28 am    Post subject: Reply with quote

The issue with V3 and read only is caused by certain characters in the user data like a comma(,) or semi-colon(;) for example. it will be fixed in 3.0.1 later this month.
Back to top
View user's profile Send private message
mike_sp
General User
General User


Joined: 19 Aug 2008
Posts: 5

PostPosted: Wed Jan 14, 2009 8:16 am    Post subject: Reply with quote

Neither option worked.

1) Using the described toolbar button:
When I move my cursor over the toolbar button, I see "Edit File"
When I click on the toolbar button, I then see the document in what I'd term "print preview" mode. That is, I can view the document but cannot click on any portion of the document and all paragraph marks are gone.
When I click on the toolbar button again, it takes me back to the original "read-only" mode, where I can position my cursor by clicking anywhere in the document and I do see the paragraph marks - but when I try to change the document in any way, I get a message that states "Readonly content cannot be changed. No modifciations will be accepted"

2) When accessing Tools>>>Options>>>OpenOffice.org>>>Security:
Read-only is not checked, in fact no boxes are checked.

I have not updated my installation of OpenOffice - it is still at 2.4.1

Since I had this problem, I have basically given up on using OpenOffice. I have access to an older version of MS Office on a network resource that I can access. OpenOffice is still the only office type product that I can install on my local PC. I just don't want the headaches associated with this product. I do freqeuntly use table of contents and hyperlinks within a document and need to be able to rely on what I use for a word processor.

I do like that OpenOffice would free me up from using yet another MS product, so if I can gain more confidence with OO maybe I can cut this tie with MS.
Back to top
View user's profile Send private message
Bug
OOo Advocate
OOo Advocate


Joined: 29 Oct 2005
Posts: 336

PostPosted: Wed Jan 14, 2009 9:14 am    Post subject: Reply with quote

mike_sp wrote:

When I move my cursor over the toolbar button, I see "Edit File"
When I click on the toolbar button, I then see the document in what I'd term "print preview" mode. That is, I can view the document but cannot click on any portion of the document and all paragraph marks are gone.

When you click on the Edit File button, you should see a message asking whether you want to open an editable version of the file. You must click Yes to open the editable version.
Back to top
View user's profile Send private message
mike_sp
General User
General User


Joined: 19 Aug 2008
Posts: 5

PostPosted: Wed Jan 14, 2009 9:40 am    Post subject: Reply with quote

The question does not appear. It goes directly to the "print preview" mode.
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Wed Jan 14, 2009 9:45 am    Post subject: Reply with quote

Are you sure that you have the original version of OOo from www.openoffice.org and not a phoney imitation?
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
mike_sp
General User
General User


Joined: 19 Aug 2008
Posts: 5

PostPosted: Wed Jan 14, 2009 9:50 am    Post subject: Reply with quote

Yes, I originally had v 2.3 on my machine, then upgraded to v 2.4.1.
Back to top
View user's profile Send private message
Bug
OOo Advocate
OOo Advocate


Joined: 29 Oct 2005
Posts: 336

PostPosted: Wed Jan 14, 2009 10:00 am    Post subject: Reply with quote

Follow these steps to repair the problem:

1. On the far right of the toolbar with the "Edit File" button, click on the downward-pointing black arrow.

2. Choose option "Customize toolbar" that appears there.

3. In the Toolbar Content section of the window, scroll down and highlight the "Edit File" button.

4. Click on the "Modify" button to the right and choose "Restore default command."

5. Click OK.

The button should work properly now.
Back to top
View user's profile Send private message
mike_sp
General User
General User


Joined: 19 Aug 2008
Posts: 5

PostPosted: Wed Jan 14, 2009 10:17 am    Post subject: Reply with quote

This had no affect. The behavior is the same. I did the steps outlined twice, once staying in the document and once getting out of the document and then back in. The results were the same both times.

What I did notice this time was the what I am calling "print preview" mode actually is "read only" mode. When I open the document and find that I cannot change anything, then press the "Edit File" button, the document name appears with "(read only)" appended to the end of it. Might not mean anything, but I thought I'd pass it along.
Back to top
View user's profile Send private message
Bug
OOo Advocate
OOo Advocate


Joined: 29 Oct 2005
Posts: 336

PostPosted: Wed Jan 14, 2009 12:56 pm    Post subject: Reply with quote

In the case as you describe, you appear to be changing the document to a read-only document because the words "read only" appear after you click the Edit File button. This is normal. The Edit File button not only opens a new copy of read-only docs. It also sets documents to read-only if they're not already. You appear to be setting a document to read only.

Therefore, I infer that the problem of not being able to edit the document in question is not related to the document's being read only. There must be another reason.
Back to top
View user's profile Send private message
mbostwick
Newbie
Newbie


Joined: 21 Jan 2009
Posts: 1

PostPosted: Wed Jan 21, 2009 8:12 pm    Post subject: Reply with quote

have you tryed this: http://user.services.openoffice.org/en/forum/viewtopic.php?f=7&t=5082&p=23744&hilit=write+protected .Open the Navigator (F5), go to the Sections tree, right click on the section entry, Edit and uncheck the Protected option in the Write protection area. Then, do what you want in the fields.
Back to top
View user's profile Send private message
davecat
Newbie
Newbie


Joined: 29 Mar 2010
Posts: 1

PostPosted: Mon Mar 29, 2010 6:59 pm    Post subject: Reply with quote

craigp01 wrote:
I've run into the same problem, except it happened in version 3 running on a fully patched XP system. Tried several ways out, including:

<snip>
There are .lock files in the directory where the document is located.
<snip>


Well, all this was a long time ago, but the .lock files sound like the culprit. At a guess they're not getting deleted when the program was closed, which suggests that it's terminating abnormally. You could try deleting them by hand before trying to edit the document, or while the document is opened read-only & then clicking on the edit-document button (paper-&-pencil).

I don't know whether that is relevant here; I just know that I encountered a similar problem which (I'm guessing, knowing the computer in question) was caused by a system crash while the document was open. Deleting the .lock file fixed the problem in that case. YMMV.
_________________
-- Dave
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group