OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

USB Printer doesn't get listed under Print dialog

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
MartinC
Guest





PostPosted: Thu Apr 01, 2004 3:51 pm    Post subject: USB Printer doesn't get listed under Print dialog Reply with quote

I installed a USB Canon printer with CUPS. I can see it in Kwrite's printer dialog, but I cannot see it in OpenOffice's one.
Is there anything special I should do with a USB printer?
I have (in other Slackware system) an Epson Stylus printer and it does get listed before installing it with CUPS.
My Linux distribution is Slackware 9.1. OpenOffice version 1.1. (I tryed reinstalling OOo, but it didn't make it)

Thank you.
Back to top
cwchia
Super User
Super User


Joined: 09 Jan 2003
Posts: 1050
Location: Malaysia

PostPosted: Fri Apr 02, 2004 2:04 am    Post subject: Reply with quote

I'm not familiar with Slackware but did you run ./spadmin from your OOo intallation path and then set the Generic Printer to lpr "YourPrinter" ... Well this is what I can recall as I'm not with my Linux box right now.

Good luck.
Back to top
View user's profile Send private message
MartinC
Guest





PostPosted: Fri Apr 02, 2004 11:16 am    Post subject: Reply with quote

No, I didn't know it.
I tried that on my computer (the one where I can see my CUPS printer), and the Generic printer has something I used before to make the USB printer to print under Dosemu: the lpr -P "CUPS_Printer_Name"

Maybe if I do that I can make it.
I would like to know why with my printer I didn't need it and for that Canon USB printer I do.

Thank you very much.
(I have just downloaded OOo 1.1.1, if it doesn't work with spadmin I'll try with the new version of OOo)
Back to top
cwchia
Super User
Super User


Joined: 09 Jan 2003
Posts: 1050
Location: Malaysia

PostPosted: Fri Apr 02, 2004 10:15 pm    Post subject: Reply with quote

MartinC wrote:
No, I didn't know it.
I tried that on my computer (the one where I can see my CUPS printer), and the Generic printer has something I used before to make the USB printer to print under Dosemu: the lpr -P "CUPS_Printer_Name"

Yes this is what I can recall when you run ../spadmin from you OOo installation path and then click on add new printer inthe spadmin dialogue. Your will be presented with another page where you can specify your printer as per your description. Again this is from my memory as my Lin Box is far far away...

MartinC wrote:
(I have just downloaded OOo 1.1.1, if it doesn't work with spadmin I'll try with the new version of OOo)

I do not think that switching to OOo1.1.1 will help in anyway if it cannot be solved in 1.1.0 as 1.1.1 is merely an enhancement of 1.1.0 and I believe that the underlying codes to printing is not changed. Anyway it is not a bad idea to use 1.1.1 as it *should* be better then 1.1.0

Good luck Cool
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group