OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Further query on address labels

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
ptoye
Power User
Power User


Joined: 16 Nov 2005
Posts: 52
Location: Reading, England

PostPosted: Wed Dec 03, 2008 8:20 am    Post subject: Further query on address labels Reply with quote

Following on from Bob Hawkins' question, I'm still not sure how to do it!

I set up a label using the wizard. Tried to add a <nextrecord> field, but nothing seemed to go into the label, whose text at the time just said <NAME><Line1><Line2> etc. However, when I clicked the "Data to Fields" icon, the labels filled up.

But I have 4 problems:

1) I only have one page. How do I get the next page of labels please? There should be about 6.

2) Only every other record is being selected. It's possible that I added a "next record" field twice, but as I can't see it I don't know which bit to try to delete.

3) Some of the data is incorrect - it comes from other rows in the same database query. What's happening here?

4) As far as I can see, not all of the fields are being correctly included (but see question below)

And a question:

Is there any way of getting back from the filled-in data to the label form with the fields? I can't even start diagnosing what the problems are without this. Or changing the label contents.
_________________
Peter
Back to top
View user's profile Send private message Visit poster's website
thomasjk
Super User
Super User


Joined: 16 Dec 2005
Posts: 2374

PostPosted: Wed Dec 03, 2008 8:39 am    Post subject: Reply with quote

First of all if you are using the label wizard the Next Record filed is automatically added. I recommend this excellent article for help http://www.freesoftwaremagazine.com/articles/mail_merge_openoffice_org .
Data to fields is not reversible and only gives one page. Set up your document first and save it as a template before doing any thing else.
Turn on View--->Field Names and you will probably see an extra Next Record field. Delete this field Turn Off View-->Field Names and click synchronize.
Click Print and answer yes to the form letter prompt. You will then be able to select all or some of your records. You can also Print to a file at this point and save the output as a Writer document.
Back to top
View user's profile Send private message
ptoye
Power User
Power User


Joined: 16 Nov 2005
Posts: 52
Location: Reading, England

PostPosted: Wed Dec 03, 2008 9:01 am    Post subject: Thanks Thomas Reply with quote

This has answered some of my queries, and the article is bound to be useful.

It also points out that there's no way of going back from the filled-in data to the template. Which isn't much use, really. OO developers take note (assuming that they read this sort of wibble).

One question, though. You say "save it as a template". Is that as an OO Template, or were you using the word "template" generically?
_________________
Peter
Back to top
View user's profile Send private message Visit poster's website
thomasjk
Super User
Super User


Joined: 16 Dec 2005
Posts: 2374

PostPosted: Wed Dec 03, 2008 9:09 am    Post subject: Reply with quote

Yes an OOo template. Then you can reload the template as needed.
Back to top
View user's profile Send private message
ptoye
Power User
Power User


Joined: 16 Nov 2005
Posts: 52
Location: Reading, England

PostPosted: Wed Dec 03, 2008 9:41 am    Post subject: Reply with quote

Hmmmm..... a bit odd, this.

I did as you suggested without saving a template, and it actually worked OK, so I can do my Xmas cards this years at least.

But then I started again, and saved the label form (with the fields) as a .ott template. Opened a new document with it, opened the data source, selected the records, clicked on the "data to fields" and nothing happens. Tried again - same thing. So there's something wrong with the template and I've no idea how to cure it. Is OO label and form handling irretrievably broken or am I being extremely stupid?
_________________
Peter
Back to top
View user's profile Send private message Visit poster's website
ptoye
Power User
Power User


Joined: 16 Nov 2005
Posts: 52
Location: Reading, England

PostPosted: Wed Dec 03, 2008 9:55 am    Post subject: Reply with quote

ptoye wrote:

I did as you suggested without saving a template, and it actually worked OK, so I can do my Xmas cards this years at least.


Oh dear, I re-opened the saved labels to print them, but it's gone back to the field view again and I can't get the database into the document again Sad
_________________
Peter
Back to top
View user's profile Send private message Visit poster's website
thomasjk
Super User
Super User


Joined: 16 Dec 2005
Posts: 2374

PostPosted: Wed Dec 03, 2008 10:46 am    Post subject: Reply with quote

Turn off View--->Field Names. CTRL-F9.
Back to top
View user's profile Send private message
ptoye
Power User
Power User


Joined: 16 Nov 2005
Posts: 52
Location: Reading, England

PostPosted: Wed Dec 03, 2008 10:56 am    Post subject: Reply with quote

OIC

Thanks again!
_________________
Peter
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group