OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Orphan / widow control doesn't work in footnotes

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
OOo-UserPeter
Newbie
Newbie


Joined: 14 Jul 2009
Posts: 2

PostPosted: Tue Jul 14, 2009 2:55 am    Post subject: Orphan / widow control doesn't work in footnotes Reply with quote

Hi everybody,

Did anyone get the orphan / widow control running in footnotes? For me it seems to be the same problem as with the orphan / widow control in tables (see this post: http://www.oooforum.org/forum/viewtopic.phtml?t=75517):

The orphan / widow control in the main body of the text works just fine.
But in the footnotes it's a nightmare: OO (version 3.1) puts, e.g., the first 3 lines of the last footnote on page 1 and the last line of this footnote on the next page. Nothing changes if I activate orphan / widow control (seperately and combined), all I can do is to deactivate paragraph splitting - but then all 4 lines of the footnote move to the second page leaving unnecessary space on the first page.
The programm could just swap the third line to the next page as well (creating a bit more space on the first page) and everything would be fine.

Any ideas? Any workarounds?
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Tue Jul 14, 2009 5:13 am    Post subject: Re: Orphan / widow control doesn't work in footnotes Reply with quote

OOo-UserPeter wrote:
Hi everybody,

Did anyone get the orphan / widow control running in footnotes? For me it seems to be the same problem as with the orphan / widow control in tables (see this post: http://www.oooforum.org/forum/viewtopic.phtml?t=75517):

The orphan / widow control in the main body of the text works just fine.
But in the footnotes it's a nightmare: OO (version 3.1) puts, e.g., the first 3 lines of the last footnote on page 1 and the last line of this footnote on the next page. Nothing changes if I activate orphan / widow control (seperately and combined), all I can do is to deactivate paragraph splitting - but then all 4 lines of the footnote move to the second page leaving unnecessary space on the first page.
The programm could just swap the third line to the next page as well (creating a bit more space on the first page) and everything would be fine.

Any ideas? Any workarounds?


No idea. I was noticing the other day that LaTeX seems to do this too, so either it is accepeted formatting !!! or just very hard to do.
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
OOo-UserPeter
Newbie
Newbie


Joined: 14 Jul 2009
Posts: 2

PostPosted: Wed Jul 15, 2009 5:36 am    Post subject: Reply with quote

I didn't expect LaTeX do have a similar problem - very interesting. As my editor asked me to remove widows and orphans in the footnotes I don't think it's accepted formatting. I hope this bug will be fixed in the future.
Back to top
View user's profile Send private message
Ardenay
General User
General User


Joined: 30 Aug 2010
Posts: 9

PostPosted: Mon Aug 30, 2010 12:17 pm    Post subject: Getting a footnote to stay on the page Reply with quote

I have the same problem as OOo-UserPeter. A footnote longer than 2 of 3 lines spills over onto the next page, which is ridiculous. Basically, when you type a footnote, however long it is, by default it should fit onto the page on which it is referenced. Some footnotes are quite long.

For the moment, it would be sufficient to consider only those cases where there is only one footnote on the page, and the footnote length does not approach the length of a page.

This is one of those apparantly trivial items that in the end render OOo totally unusable for serious work (in my case scientific writing), because there seems to be no straightforward workaround. I wasted a lot of time fiddling around with the options, but found nothing useful.


Regards
OOo 3.2.1
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Mon Aug 30, 2010 12:59 pm    Post subject: Reply with quote

I'm not so sure of that - I've seen a lot of scientific texts with footnotes overflowing to the next page, in some cases it just can't be avoided. And, with all due respect, please keep in mind that OOo was never intended as a desktop publishing tool, even if the majority of its users seem to regard it as one.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Tue Aug 31, 2010 6:21 am    Post subject: Re: Getting a footnote to stay on the page Reply with quote

Ardenay wrote:
I have the same problem as OOo-UserPeter. A footnote longer than 2 of 3 lines spills over onto the next page, which is ridiculous. Basically, when you type a footnote, however long it is, by default it should fit onto the page on which it is referenced. Some footnotes are quite long.

For the moment, it would be sufficient to consider only those cases where there is only one footnote on the page, and the footnote length does not approach the length of a page.

This is one of those apparantly trivial items that in the end render OOo totally unusable for serious work (in my case scientific writing), because there seems to be no straightforward workaround. I wasted a lot of time fiddling around with the options, but found nothing useful.


Regards
OOo 3.2.1


Personally I'm of the opinion footnotes should be banned. Smile

Have a look at the footnote tab in your page styles. My rough test showed that I could insert 2 footnotes with a total of 42 lines with no problem. Alternatively I inserted 4 footnotes with text ranging fron 5 lines to about 15.


My footer tab setting was not larger than page size
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group