OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

How to change default paragraph line breaks ?
Goto page 1, 2  Next
 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
jwalker
General User
General User


Joined: 16 Apr 2005
Posts: 9

PostPosted: Sat Apr 16, 2005 10:12 am    Post subject: How to change default paragraph line breaks ? Reply with quote

I would like to change the default styles so that "enter" starts a new line withOUT skipping a line...in other words, it works, on all docs and in all places, just like Word.

I realize that format/paragraph can change this for selected text, but that doesn't help with my default settings. I have checked "body text" and "default", but they show "spacing above/below paragraph" as set to zero.

With apologies if this is explained somewhere, but I can't find an explanation in the docs or on this forum.

Thanks in advance !

jw
Back to top
View user's profile Send private message
9point9
Moderator
Moderator


Joined: 31 Aug 2004
Posts: 3875
Location: UK

PostPosted: Sat Apr 16, 2005 10:35 am    Post subject: Reply with quote

The 'default' style does not do this. The 'text body' style does when it gets applied. To modify a style bring up the context menu on the section of text that has had the style applied and slect 'Edit Paragraph Style'. Then go to the 'Indents and Spacing' tab and under the 'Spacing' section set the space below (or above in some styles) a paragraph to zero. By default 'text body' has it set to 2.16mm.

The default for text should be unaffected by this. The user would have to apply a style to the text to change the spacing.

That works for me on both 1.9.93 and 1.1.4, not sure how you've not got it to work.
_________________
Arch Linux
OOo 3.2.0

OOoSVN, change control for OOo documents:
http://sourceforge.net/projects/ooosvn/
Back to top
View user's profile Send private message Visit poster's website
8daysaweek.co.uk
Super User
Super User


Joined: 29 Nov 2003
Posts: 2130
Location: UK

PostPosted: Sat Apr 16, 2005 10:36 am    Post subject: Reply with quote

I assume you've missed the stylist Wink

Press F11 to access the stylist, in there you can change all setting for the default paragraph style.

If you want the document with these changes to be the default template for all new documents, you need to save it as your default template:
http://www.8daysaweek.co.uk/forums/viewtopic.php?t=53

HTH Smile,
_________________
James
www.8daysaweek.co.uk - A User-Focused OOo site
Back to top
View user's profile Send private message Visit poster's website AIM Address
jwalker
General User
General User


Joined: 16 Apr 2005
Posts: 9

PostPosted: Sat Apr 16, 2005 11:35 am    Post subject: Reply with quote

Thank you both for your reply. And, yes, I have found and edit Stylist.

However, the "text body" is set to "0.00" before/after and......it still skps a line between paragraphs.

I have checked EVERY "applied style" and ALL have "0.00" spacing before/after. But, whenever I hit "enter", it skips a line.

(OpenOffice 1.1.4)

With apologies if I've missed something very elementary........try a more specific recommendation, please?

From a typewriter (many decades ago) to Word, "enter" is normally "skip one line". It is hard to relearn decades of typing............help would be most welcome.
Back to top
View user's profile Send private message
9point9
Moderator
Moderator


Joined: 31 Aug 2004
Posts: 3875
Location: UK

PostPosted: Sat Apr 16, 2005 11:51 am    Post subject: Reply with quote

It skips a whole line? Is this in the sense that there is a line between that you can type text on or is it double spacing between 2 lines. Which ever way it is it isn't how it works for me.

Is this in all files? Which file types have you tried? If the file gets saved as something else does it remove these line gaps? If you have non-printing characters enabled, what character shows up for the line gap?

It is not an OOo default thing so I wouldn't jump to saying that it is OOo's fault for the moment. If it's a setup problem that can't be identified then reinstalling OOo would fix it.
_________________
Arch Linux
OOo 3.2.0

OOoSVN, change control for OOo documents:
http://sourceforge.net/projects/ooosvn/
Back to top
View user's profile Send private message Visit poster's website
jwalker
General User
General User


Joined: 16 Apr 2005
Posts: 9

PostPosted: Sat Apr 16, 2005 12:13 pm    Post subject: Reply with quote

9point9"

Skips a line = if you hit "enter" twice in Word (or hit "return" twice on a typewriter), then there is a space (an empty line) bewteen two paragraphs.

EXAMPLE:
name
address
city

Is "normal" line spacing in Word on a typwriter.

In OO, "enter" after each word results in:

name

address

city

i.e., an empty line between each "paragraph".


You wrote, "It is not an OOo default thing " Yes, it is; see:

http://www.tutorialsforopenoffice.org/tutorial/Create_A_Tutorial.html
"Press Enter. (The cursor moves down two line to begin a paragraph.) "

However, the point is: please help and tell me how to change this setting IN STYLIST (i.e. for ALL docs).

Please ????
Back to top
View user's profile Send private message
9point9
Moderator
Moderator


Joined: 31 Aug 2004
Posts: 3875
Location: UK

PostPosted: Sat Apr 16, 2005 12:53 pm    Post subject: Reply with quote

Yes, I understand what you meant by line breaks. I didn't require a deeper explanation, what I'd like to know is how does it appear? As a spare line on which text can be written or as just a gap between 2 lines.

jwalker wrote:
You wrote, "It is not an OOo default thing " Yes, it is; see:

http://www.tutorialsforopenoffice.org/tutorial/Create_A_Tutorial.html
"Press Enter. (The cursor moves down two line to begin a paragraph.) "


No it isn't. If you look at the previous step you can see that that is with 'Heading 1' applied which will give double spaces. With no style, it puts in single line breaks by default.

jwalker wrote:
However, the point is: please help and tell me how to change this setting IN STYLIST (i.e. for ALL docs).

Please ????


By all means, just answer the questions that I asked before so that I can help you narrow it down.
_________________
Arch Linux
OOo 3.2.0

OOoSVN, change control for OOo documents:
http://sourceforge.net/projects/ooosvn/
Back to top
View user's profile Send private message Visit poster's website
jwalker
General User
General User


Joined: 16 Apr 2005
Posts: 9

PostPosted: Sat Apr 16, 2005 1:27 pm    Post subject: Reply with quote

9point9:

>It skips a whole line? Is this in the sense that
>there is a line between that you can type text on

Yes

>Is this in all files? Which file types have you tried?

*.sxw only. I want to change to Linux, so I'm first trying to conver all my files from Word to OO....I certainly don't want to keep the *.doc file type.

>It is not an OOo default thing

I disagree.....I have not changed any Style to add spacing before/after paragraphs.

To illustrate the problem: for a certain subset of text, if you go to
format/paragraph
the default is 0.20" beneath a paragraph.

My system acts as if that is the default for ALL paragraphs, and I simply want to change it globally (i.e. in Styles).

I apologize if I appear frustrated.....I am. Wink

Thank you for your patience.
Back to top
View user's profile Send private message
9point9
Moderator
Moderator


Joined: 31 Aug 2004
Posts: 3875
Location: UK

PostPosted: Sun Apr 17, 2005 1:20 am    Post subject: Reply with quote

I can't reproduce this. As I've said before the default does not insert a spare carriage return at the end of a paragraph. I've never seen that happen in any of the installations of OOo that I've had on any system.

If you can't get rid of it then you could completely uninstall and reinstall OOo, that would restore it to the default settings. If you're certain that you've not changed any of the settings and reinstalling doesn't help then perhaps you should put something in Issuezilla. Have you searched it yet? There may already be something on this.
_________________
Arch Linux
OOo 3.2.0

OOoSVN, change control for OOo documents:
http://sourceforge.net/projects/ooosvn/
Back to top
View user's profile Send private message Visit poster's website
jwalker
General User
General User


Joined: 16 Apr 2005
Posts: 9

PostPosted: Sun Apr 17, 2005 2:06 am    Post subject: Reply with quote

9point9,

Thank you again for your effort and patience.

Let me try a slightly different explanation:

If you go to Writer's Help, and enter "line breaks" then click on "inserting", you will see a line break defined as "Ends the current line, and moves the text found to the right of the cursor to the next line, without creating a new paragraph. You can also insert a line break by pressing Shift+Enter."

What I find on my install is that, within a paragraph of text ("text body" style), "enter" = new paragraph = double spacing. "Shift+enter" = one line break = "ENTER" in MS-Word.

The concept of "new paragraph" is new to me....in Word, as on a typewriter, you create a paragraph by hitting "enter" twice....and that is the behavior I want to mimic in OO. So,
I want the default "new paragraph" to be one line down, i.e. without skipping a line (inserting a blank line).

Is that more clear? ("No" is an acceptable answer!)
Back to top
View user's profile Send private message
9point9
Moderator
Moderator


Joined: 31 Aug 2004
Posts: 3875
Location: UK

PostPosted: Sun Apr 17, 2005 3:00 am    Post subject: Reply with quote

I don't need another explanation but what you've now said conflicts with what you said earlier. I thought that you had meant that it leaves a whole line on which you could type, as that is how you answered my earlier questioning.

It's now clear that it is the space between paragraphs on certain styles that you don't like. Just set it to 0. Without any style applied this is what happens. I think Winword does actually insert paragraph breaks in some of the styles anyway. Create a new style with the spacing between paragraphs set to 0.
_________________
Arch Linux
OOo 3.2.0

OOoSVN, change control for OOo documents:
http://sourceforge.net/projects/ooosvn/
Back to top
View user's profile Send private message Visit poster's website
jwalker
General User
General User


Joined: 16 Apr 2005
Posts: 9

PostPosted: Sun Apr 17, 2005 3:53 am    Post subject: Reply with quote

9point9;

I apologize that my earlier answer was not correct.

However, in my first post, I stated that I HAVE set the paragraph settings to zero for "body text" and "default". If I open a new doc with my default template and start typing, there's no problem.

If your patience is holding out, please see if you can duplicate this:
(1) Open a template with "default" and "text body" set to "0" above/below paragraph spacing. (2) Then, copy/paste from a Word doc. (3) Place the cursor anywhere in normal text (not headline etc syles), and then hit "enter".

When I do that, enter = new paragraph, with spacing between the paragraphs........but the styles ARE set to "0" spacing before/after paragraphs. I don't see anything else that can be changed.

If, after pasting the Word doc into OO, I set the entire doc to "default", then I don't have this problem....but I then have to reformat every chapter and section heading in every single Word doc and.....that would take years (literally).
Back to top
View user's profile Send private message
9point9
Moderator
Moderator


Joined: 31 Aug 2004
Posts: 3875
Location: UK

PostPosted: Sun Apr 17, 2005 4:02 am    Post subject: Reply with quote

jwalker wrote:
(1) Open a template with "default" and "text body" set to "0" above/below paragraph spacing. (2) Then, copy/paste from a Word doc. (3) Place the cursor anywhere in normal text (not headline etc syles), and then hit "enter".


That doesn't happen for me. I just get standard line spacing. Put it in Issuezilla if you want.
_________________
Arch Linux
OOo 3.2.0

OOoSVN, change control for OOo documents:
http://sourceforge.net/projects/ooosvn/
Back to top
View user's profile Send private message Visit poster's website
jwalker
General User
General User


Joined: 16 Apr 2005
Posts: 9

PostPosted: Sun Apr 17, 2005 7:33 am    Post subject: Reply with quote

9point9,

Thank you very much for your patience and effort.

jw
Back to top
View user's profile Send private message
millierl
Newbie
Newbie


Joined: 30 Sep 2009
Posts: 1
Location: NYC

PostPosted: Wed Sep 30, 2009 11:05 pm    Post subject: Can confirm extra space between paragraphs set to 0 Reply with quote

Hi! First posting here, so be gentle.

At first I didn't think JW's problem had anything to do with mine, until he said that he had opened a file originally saved with MS-Word. That made me realize that our problems are the same.

Here's what I did. I have a little one page flyer that I put together with MS Word. The flyer has no multi-line paragraphs in the conventional sense; each line ends with a carriage return. Like this:

Come see a great show!

Featuring:
Lots of great people

Thursday at 8pm
Free

That sort of thing. Naturally, each line ends with a carriage return/Paragraph mark. When I opened it in OO3 (on XP) it took up too much vertical space, and my little one page flyer spilled over onto two pages. At first I thought it was the dreaded "line-space" issue I had experienced with OO on Ubuntu, but that was indeed resolved with MS Core fonts. In this case, I WAS using MS fonts by definition, because I'm running OO under XP.

So I did a little experiment, and manually replaced each Carriage Return with a LINE BREAK (using shift-enter), and VOILA! It appeared almost exactly as it had in Word. It seems that even though every single style is set with a Paragraph Spacing to 0, both before and after, there is simply no way to get OO to not add extra space between the paragraph marks. In my case, it is not a full line, as it is with JW, but rather just a partial line, maybe equivalent to text with point size 2 or 3. But it is equally frustrating.

By the way, I also tried "Edit Paragraph Style", which I THINK changes any referenced styles, but no luck. Obviously there is a glitch with how oO handles styles created in MS-Word. (It can't be a font substitution issue; all the fonts are there. Plus, the only font I'm using is Cooper Black, which is standard, and works just fine with a new file in Writer.)

Obviously, if paragraph spacing is set to before=0 and after=0, and the line spacing is also set to "single", there should be no visible difference between hitting Enter and Shift-Enter, as both CR and LF should simply advance to the next line. But in this case, due to some linking between styles, or SOMETHING, extra space is being added between paragraphs that CANNOT be excised without stripping the formatting and starting over.

I would appreciate ANY help on this. I have an entire library of flyers like this I'd like to cannibalize for new projects, but until this is resolved, I'll have to stick with MS-Word.

Will happily email the file to someone if it helps.

Thanks,
MRL
_________________
MLR
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group