OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

I'm only trying to sort 3 terms! Why doesn't it work??

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc
View previous topic :: View next topic  
Author Message
languagedan
Newbie
Newbie


Joined: 12 Feb 2009
Posts: 4

PostPosted: Mon Mar 22, 2010 3:45 pm    Post subject: I'm only trying to sort 3 terms! Why doesn't it work?? Reply with quote

I can't figure this out for the life of me. Already spent an hour on this simple problem!

I open a new spreadsheet and copy/paste these values into the A column:
Arabic
Japanese
Chinese

I sort Descending, and get:
Arabic
Japanese
Chinese

Why doesn't Arabic get sorted?? I've tried sorting with the buttons, through the Data > Sort.. menu, selecting and deselecting every option, with no good results. Tried it in MS Office, and the sort worked as expected.

My sample data is a simplified version of a long list of 31 languages.

Thanks in advance!

--Daniel[/list]
Back to top
View user's profile Send private message MSN Messenger
ken johnson
Super User
Super User


Joined: 23 Apr 2009
Posts: 2032
Location: Sydney, Australia

PostPosted: Mon Mar 22, 2010 4:16 pm    Post subject: Reply with quote

Calc is probably treating "Arabic" as a label.
If this is the case then after going Data|Sort, which brings up the "Sort" dialog, click on that dialog's "Options" tab then deselect "Range contains column labels".

Ken Johnson
_________________
If your problem has been solved please add "[Solved]" to the beginning of your first post title (edit button).
Back to top
View user's profile Send private message
languagedan
Newbie
Newbie


Joined: 12 Feb 2009
Posts: 4

PostPosted: Mon Mar 22, 2010 4:27 pm    Post subject: Reply with quote

Ok, figured it out. The problem is that every time I de-selected "Range contains column labels", then resorted using the toolbar buttons, "Range contains column labels" would get selected again on it's own!

Why?? If I de-select it, it should stay deselected until I select it again myself. So much needless suffering. Hope this can be fixed someday.

My version of OOO is 3.1.1 on Windows XP.

Thx.

-Daniel
Back to top
View user's profile Send private message MSN Messenger
Villeroy
Super User
Super User


Joined: 04 Oct 2004
Posts: 10106
Location: Germany

PostPosted: Tue Mar 23, 2010 12:18 am    Post subject: Reply with quote

Select the range.
Data>Define...
Give a name to your range and check the column label option.
Data>Sort will keep all settings.
Data>Refresh will sort the modified range in one step.
_________________
Rest in peace, oooforum.org
Get help on https://forum.openoffice.org
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group