OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

%symbol weirdness

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Math
View previous topic :: View next topic  
Author Message
sysKin
Guest





PostPosted: Sat Apr 24, 2004 12:25 am    Post subject: %symbol weirdness Reply with quote

Hi everyone,

Following my success using writer/maths for my mathematics assignments at uni, I started using OO for my electrical engineering homework. However, to my surprise, I am starting to have more and more problems.

The 1st one: default %symbol characters are not substituted with corresponding unicode characters from the font I am using. This wouldn't be a problem, but the symbols actually used are italics, which looks funny when I'm trying to use %OMEGA as Ohm symbol.

Should the symbols look like this? If someone wants to use italics he can always activate it: "italics %OMEGA". Currently this, however, makes omega double-italics...

Anyway, I used "Symbols" page to change the %OMEGA to the corresponding "Times New Roman -> Basic Greek -> Capital Omega" symbol. I don't expect to change the font I'm using so it's fine. Another problem popped up:

2nd problem: the actual symbol inserted now is too big. My Maths is defined to use font 10, and the new %OMEGA is definitely font 11. Is that a bug? I can only get the "correct" size by writing "size 9 %OMEGA" - to get size 10.

3rd problem is quite known on this forum - spaces. Both before and after any %symbol there are unwanted spaces that can't be removed. This looks bad of course... "mA" should not be so much different from"%mu A", just like "k%OMEGA" should not have the space in it either...

Are there any plans to help with this? A binary operator "nspace" would be simply perfect, useful for many other occasions ("int vec F cdot d nspace vec v").
Perhaps I should fill a bugzilla feature request about that?

As for now, I'll be just copying-and-pasting Unicode symbols into the equation code, which is a poor workaround - good thing I don't have that much to write.

I'd like to thank everyone for this excelent piece of software. I didn't write this post to complain (I couldn't even start doing all that with competition's tools) but in a hope that it will make things even better in the future.

Regards,
Radek

PS. Oh right, I'm using OO 1.1.1RC4 on windoze2k.
Back to top
fluitr
Guest





PostPosted: Sat Apr 24, 2004 5:17 am    Post subject: Reply with quote

Hi,

Formula layout takes some time to get used to. A few times issues have been discussed in this forum. Your questions:

1) The margins around formulas are too big. You can set this under Format – Styles- Catalog- Frame styles – Formula -Modify -Wrap

Set the margins at 0 for all four and your gaps will be reasonable. After setting your preferences click on standard and all new formulas will use your changes.

2) There is italics in the formula. You can set this as follows:
Open a formula by double clicking on it. Format – Fonts- Modify and play around with what you want. When you are done click on default. All new formulas will use your changes. (Not the ones you created before, unfortunately)

3) Formatting the text around a formula does not format the formula accordingly. I do not think that this is possible. At least I have not found a way. A solution is to decide what you will use for the document and put these settings before hand in the formula settings. (See my 1 and 2). Unfortunately when you don´t like the font, the size etc afterwards, you will have to change them one by one. (I think?)

4) Adding a problem: Doing the above leaves me with the problem that some of my formulas do not exactly follow the line of text. they are slightly above or below the text. This depends on how much height the formula has.

Richard
Back to top
sysKin
Guest





PostPosted: Sat Apr 24, 2004 5:48 am    Post subject: Reply with quote

fluitr wrote:
1) The margins around formulas are too big. You can set this under Format – Styles- Catalog- Frame styles – Formula -Modify -Wrap
Thanks for the info... but as far as I'm not sure that I made myself clear (happens all the time) I'm reasonably sure that my question was not about spaces around the formula, but within it. I was asking if this problem is under development or not. It would be nice if it was, I've proposed a solution.
Quote:
2) There is italics in the formula. You can set this as follows:
Open a formula by double clicking on it. Format – Fonts- Modify and play around with what you want. When you are done click on default. All new formulas will use your changes. (Not the ones you created before, unfortunately)
That's not what I meant. Imagine the following formula:
nitalic %OMEGA ~~~ italic %OMEGA
I would expect the first omega symbol to be straight, the second one - italic. This is not the case, the first one is italic and the second one is super-italic. There is no way to get the "normal" greek symbols without changing the meaning of %OMEGA to actually use different font (which has to be done one-by-one for all greek symbols used - it *can't* be done from Format – Fonts- Modify, or at least I don't see how.
Quote:
3) Formatting the text around a formula does not format the formula accordingly. I do not think that this is possible. At least I have not found a way. A solution is to decide what you will use for the document and put these settings before hand in the formula settings. (See my 1 and 2). Unfortunately when you don´t like the font, the size etc afterwards, you will have to change them one by one. (I think?)
Ugh that's a big misunderstanding again..
Do this:

open a formula, go to tools->catalog, click on, for example, "ALPHA" and modify it to use normal letter "A" from the same font you are using for your formula. Now, type:
%ALPHA ~~ "A".
You have just defined alpha to be the same "A" but they are different, the %ALPHA is exactly one point bigger... actually I just tried playing with it and it doesn't happen all the time. It's random. Must be a bug.

Thanks for your answer,
Radek
Back to top
fluitr
Guest





PostPosted: Sat Apr 24, 2004 11:10 am    Post subject: Reply with quote

Hi,

I did not read your questions carefully enough, and merely unswered what i thought you asked My students do that all the time. I see your problems, but I see no solutions besides changing each and every entry in the catalog , but you metnioned that already.

I hope someone else has ideas,

Richard
Back to top
sysKin
Newbie
Newbie


Joined: 24 Apr 2004
Posts: 2

PostPosted: Sat Apr 24, 2004 8:52 pm    Post subject: Reply with quote

I wrote:
actually I just tried playing with it and it doesn't happen all the time. It's random. Must be a bug.
OKay I don't like to leave a bugreport like this. I'll now give you some exact steps to reproduce it, which turns out not to be easy. It's valid for 1.1.1rc4, I might try 1.1.1 final if you want. I use win2k. I hope it's useful.

1. open writer, start a new formula, and change the following parts of its config:
- fomat-> font size 10 (does not happen with 12)
- tools->catalog->ALPHA->modify-> times new roman capital letter "A".
- just make sure that the standard font for text is also times new roman, size 100% (format->fonts, format->font size).
Save all this as new defaults.

2. close writer. this is important.

3. start writer again, start a formula, enter "%ALPHA "A""
What I get at this point is this:

The %ALPHA symbol is size 12, the "A" is size 10.

4. you can confirm that strange things happen: click on format->font size, don't change anything, just click "ok". The %ALPHA will suddenly get correct size. From now on, this formula will not suffer from the problem anymore, ever.

5. tap 'esc' twice, start a new formula, enter "%ALPHA "A"". You will notice that this second formula suffers from the same problem again. Any new formula will suffer from it until it "miraculously" heals.

My guess is that something goes wrong with font size initialization.

I hope that's useful, and I hope developers are reading this. I might try helping (I am an OS developer myself, xvid project, if you're interested) but I never tried compiling OO before. Anyway, if developers can confirm the problem, I guess fixing it will be easy.

Thanks for reading all this,
Radek
Back to top
View user's profile Send private message
sysKin
Newbie
Newbie


Joined: 24 Apr 2004
Posts: 2

PostPosted: Sat Apr 24, 2004 9:35 pm    Post subject: Reply with quote

Hi again,
The above steps-to-reproduce are unneccessarly complicated.

I am now downloading 1.1.2rc. If I confirm the buglet in it, I'll fill in a bugzilla bug. And update this post to include its #.

Regards,
Radek

[edit]Confirmed with 1.1.2RC, and filled a bug #28339
Back to top
View user's profile Send private message
omegalove
Guest





PostPosted: Tue Jun 15, 2004 2:33 pm    Post subject: OMEGAFONTS Reply with quote

Wink HI I was wondering if any of you knew where to get the OMEGA fonts used on the OMEGA watch website? I have been searching for days and days and need it for a project. I have seen so many fonts I am dreaming of them....AHHH the headache I have,,
If you could have please email me at macupryk@videotron.ca

Thank you,
Matt
Back to top
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Math All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group